LDAP setup stuck on Automatic Verification

Honored Contributor
We did have LDAP working with a Linux infrastructure manager server, but it stopped working. We suspect the server may have been deleted from AD, but because no one here is a Linux expert we couldn't do any real troubleshooting - we couldn't even login to it. We decided to just build a new Infrastructure manager server but this time do it on a Windows server. We gave it the exact same hostname and IP as the previous one that we decommissioned so the firewall rules would all still point to the same location. At first we thought the new server could just slide in and pick up the role and restore LDAP but I found that when this new server enrolled, it created a new instance. I figured that's ok. I'll just give it a difference display name so I'll know where to point the new LDAP config. I cloned the existing LDAP config but changed the display name and pointed it to the new infrastructure manager instance.


The new infrastructure manager (on Windows server) is listed as a viable Jamf Infrastructure manager server and it is reporting as successfully checking in every 30 seconds. When I setup the LDAP connection and hit save, I got the following alert across the top of the page:
I've waited over an hour and it is still stuck verifying. How long should this take?
I verified that all the ports are identical to the old config. The only thing that should be different is the specific JIM instance we're using. Do I keep waiting or is there something I'm missing?
The only thing I can find in the server log is a bunch of entries like this that started at the same time I clicked Save on the new LDAP config:


2022-10-06 16:41:01,223 [WARN ] [ina-exec-71] [LpsServerSettingsHelper  ] - Unable to find Jsam id associated with LPS Connection Settings id [1]
2022-10-06 16:41:43,305 [ERROR] [na-exec-110] [lientCommunicationServlet] - Error processing communication content - net.sf.qualitycheck.exception.IllegalNullArgumentException: Argument 'version' must not be null.



Honored Contributor

I deleted the clone of the original LDAP connection and decided to build a new one from scratch. I built it to the specifications I know it to be but it still fails to connect. The one thing that is consistent in everything I try is the 

Unable to find Jsam id associated with LPS Connection Settings

error in the log. I can't figure out what on earth that is supposed to mean. What is a "Jsam id" and what is "LPS" and where do I find these "LPS Connection Settings"??

Honored Contributor

Hmmm.... it looks like it works now. I wish I could say exactly what it was that fixed it, but I think it might have been a combination of things.  All I can say is if you experience this yourself, you may need to work with your AD admins to make absolutely sure every setting for your environment is correct.