Local Jamf Account not Authorizing on Production API Interface

Utilizator
New Contributor III

Hi all,

Just trying some API integration and the local Jamf account we have configured for API will not authorize to generate a token on our API page:

https://mycompany.jamfcloud.com/api/doc/

It just keeps saying "Authorization failed." and wondered if it's the privileges on the account. We have it set as follows:

  • Read-Only on all Server Objects (apart from API intergrations which is set to create, read and update).
  • No permission for any Server Settings
  • No permission for any Server Actions

Am I missing something? Any help appreciated!

3 REPLIES 3

Hugonaut
Valued Contributor II

@UtilizatorIn the Jamf Pro Dashboard -> Settings -> System Settings -> User Accounts and Groups -> Click "Password Policy" in the Top Right Corner of the User Accounts and Groups Page.

 

Do you have "Allow Basic authentication for the Classic API" Checked? This is a good place to start troubleshooting.

 

Screenshot 2022-11-17 at 10.53.20 AM.png

Otherwise, please share all of your Permissions for your API User

________________
Looking for a Jamf Managed Service Provider? Look no further than Rocketman
________________


Virtual MacAdmins Monthly Meetup - First Friday, Every Month

Utilizator
New Contributor III

Hi @Hugonaut , yes that is turned on.

Utilizator
New Contributor III

@Hugonaut  the settings are group based and as follows:

  • Read-Only on all Server Objects apart from API Intergrations which is set to create, read and update.
  • No permission for any Server Settings
  • No permission for any Server Actions

Thanks.