MAC updates broke deployments (artifact uploads to S3)

New Contributor II

Hi all. I have had a user raise a ticket recently, where the latest Mac OS Update has broken deployments running from the laptop using framework.

Example error log:

Serverless: Uploading artifacts... Serverless: Uploading service api-1.0-SNAPSHOT-fat.jar file to S3 (26.47 MB)...Serverless: [AWS s3 200 0.16s 0 retries] createMultipartUpload({ Bucket: 'shared-serverless-deploys-eu-west-1', Key: 'serverless/evcharger-proxy-api/rroxa/1620983925186-2021-05-14T09:18:45.186Z/api-1.0-SNAPSHOT-fat.jar', ContentType: 'application/zip', Metadata: { filesha256: 'r7g2Ec+XYLwU4IHRrHXuaSR+cV86tq4KMymAwf2+08k=' } })Serverless: [AWS s3 undefined 10.459s 3 retries] uploadPart({ Body: <Buffer e0 b0 33 b8 3d 1f 01 13 58 55 6d 74 c0 33 da 28 37 fa 31 33 1b ad c1 9c 8b d5 d6 6c 07 07 79 db e3 59 44 fc ae e5 0c 2e 8b 4c e1 72 4e a3 ad 53 b8 42 ... 5242830 more bytes>, ContentLength: 5242880, PartNumber: 2, Bucket: 'shared-serverless-deploys-eu-west-1', Key: 'serverless/evcharger-proxy-api/rroxa/1620983925186-2021-05-14T09:18:45.186Z/api-1.0-SNAPSHOT-fat.jar', UploadId: 'ycr6amswqAbI.YLBEk7SZaKWxhKDENDhRa4d2V8d_O5yp3dRzG3zFwrOg_3OkFBEHZ9eK15ZxbcMPlKWeCPOokSjevbK.EyYWJCYKf8.CpldUGypex3A3yHv5itp_apP' })Serverless: Recoverable error occurred (write EPIPE), sleeping for ~5 seconds. Try 1 of 4

Only happens if we run it from our laptops, and across all the projects. The same framework and codebase is completely happy when ran from something like AWS CodeBuild image

Any help/support from the community would be great!



Valued Contributor

I don't have much to offer here but do you know what version of macOS the affected are on? I've seen a lot of chatter around the 10.14 update and its affects on mobile accounts, and 11.4 having is own host of problems.

New Contributor II

This seemed to have happened since Big Sur update 11.3.1

New Contributor

I have recently updated my macOS and experiencing the same issue. Spent countless hours trying to figure out exactly what went wrong. The only recent change I have was upgrading macOS and no change to other components or configurations.

I have reinstalled Python, Node, and Serverless and switching between versions all with no luck. Seems like this issue happens when the uploading artifact is more than certain size - probably 5MB since that's the trigger for multipart upload. If I remove all dependencies and try deploying a empty package, < 1MB, the whole deploy process runs smoothly.

I have also tried to upload the same large .zip file to the same bucket Serverless creates using AWS S3 CP command line and it works just fine.

I had my coworker, who also has a MBP but with 11.2.3, trying the sls deploy process with my credential. It worked fine with the same version of Python, Node, and Serverless...

Not sure if this is a Serverless or Node compatibility with 11.3.1+ issue or what, it is very frustrating :(.
I am going to just manually upload the newer code to S3 bucket for now and see if that works for the interim.

Hopefully someone can resolve it soon...