Mavericks Server + NetBoot = Nightmare

Contributor II

I have an open call with Apple Support as well as a thread on their forums with no real responses, so I thought I would post this here:

Since migrating our NetBoot servers to Mavericks. NetBooting has become flaky and recently almost always fails. Typically the clients show the globe, then appear to be booting the (diskless) NetBoot image but they never advance past this point. I followed all the steps in kb article OS X Server: Diskless NetBoot troubleshooting (, but nothing helped.

The issue is intermittent—usually a reboot will "fix" the problem but it returns after a while. The logs show me little of value. I see no BSDP related errors or anything like that.

Has anyone else seen issues like this or is this unique to my environment?



I experienced similar issues after migrating to Mavericks Server. I abandoned Mavericks Netboot all together and opted for the NetSUS and it's working well for me.

I've been pretty frustrated with Mavericks server all the way around. Because of this issue:
I've had to schedule my servers to reboot every midnight which feels really icky. And sometimes DHCP still tanks in the middle of the day necessitating a forced reboot with the power button. And OD problems. And on and on...

Contributor II

Our situation is dire enough that I am downgrading the servers to Mountain Lion. I will look into the NetSUS option long term as well. How do you find managing it?

Valued Contributor II

I've really only had problems when booting across ip ranges on 2010 machines, but that has to to with some firmware that was applied to them that changed the TFTP timeouts, but of course Apple won't fix it. If they boot from a server on the same switch it fine.

Valued Contributor II

Don't forget the NetSUS appliance won't allow you to host multiple netboot images across VLANs if you need that.

Contributor II

Thanks for noting that Casper Sally. That makes it a non starter for us.

Valued Contributor II

There is a known issue with the kernelcache file being > 32 MB but TFTP not supporting files larger than 32 MB. There are some workarounds posted in this very forum by @Lotusshaney, or on his blog at:

Contributor II

That is interesting. My original issue is general unreliability of net boot at all.

I have seen the issue you described but oddly it worked initially, then we started seeing the unbootable drive error.

Valued Contributor II

Interesting. I wonder what the breakdown is on this. Oddly, I have no netboot problems from the following configuration

Netboot, SUS, caching AND secondary replication point on 10.8.5 (with sever 3.0.3)
.nbi is 10.9.1 currently with Casper Imaging 9.22 (not going to C Imaging 9.23 or 9.24 due to known issues)
.nbi was created from a 10.9.1 iMac before being placed on the 10.8.5 server.

With that said, I've got a few other issues that seem to be related to the ever present and fun unexpected recon errors.

New Contributor

I had an issue with netbooting, well thought I did. I had the netboot working fine. Turns out I had to make an all new netboot set. Old, working sets didn't work with 10.9. When I made the new set, normally I had to have the dhcp box checked. In this case, that had to be left unchecked.

As it is probably important here, I use Deploy Studio, and I had to use a nightly build that was done in Feb 2014. After that, netbooting has worked fine.


I've built an isolated test NetBoot environment, using a MacMini server running 10.9.2 and Server 3.0.3. Setting up the machine connected to a gigabit "dumb" switch, I have no problem booting to an Apple 10.9.2/Mavericks RESTORE image NBI built from Apple's downloaded 10.9.2 image from the store (using System Image Utility).

HOWEVER, I then image up a machine (I've tried 2013/14 MBP Retina, Mid 2013 MBP, and even an older 2011 MBP), all up-to-date to 10.9.2. I put that machine into target mode and using that machine, I can boot to any other machine I have (those listed here and more!).

I use that targeted machine (MBP Retina) to build the NBI, and once done, I set it as my NetBoot. Low-and-behold, the ONLY machine it'll netboot, is the Retina. If I build an older machine to 10.9.2 and target it, again, no problem booting anything, but turning it into an NBI results in FAIL!

I can't seem to get all machines to use that image although I read that 10.9.2 is a universal OS.

Is there another tool to use to build the NBI besides Apple's System Image utility?
Am I missing a step?
I didn't have any issues building a 10.8.3 NBI last year and have no issues in the past.

Anybody? Thoughts?

Valued Contributor II

See this thread

There is a script at the bottom that helps clear up a kernelcache issue.

The problem is that SIU in 10.9 sometimes creates kernelcache files larger than 32 mb. As per the thread the issue has been reported to apple and this fix is proving quite reliable in production! This also happens to be quite reliable in my case, so far.