Missing Apple keyboard from iMacs


We have 200+ iMacs in our school environment.
Randomly it seems, the iMacs lose connection to the keyboards and stops working.
I know when its not working as when i walk past the iMac it will have the bluetooth keyboard setup wizard on display. I run the following command from ARD

ioreg -p IOUSB | awk -F'@' '{print $1}' | sed -e 's/|//g;s/+-o//g;s/^ *//g'

and i get the following results

Root <class IORegistryEntry, id 0x100000100, retain 16> Root Hub Simulation Simulation IOUSBHostDevice IOUSBHostDevice BRCM20702 Hub Bluetooth USB Host Controller Root Hub Simulation Simulation IOUSBHostDevice FaceTime HD Camera (Built-in) Root Hub Simulation Simulation Apple Optical USB Mouse

There should be an "apple keyboard" & " keyboard hub" listed.
I have tried reseting the nvram using

nvram -c

but still not luck.
This seems to happen randomly and we have not been able to work out why.
If we plug another keyboard into the same USB port it seems to work.
A restart does not seem to fix the issue.
I think a SMC reset will work but i need to find a way of doing it form JSS or a script / command

When students realize the keyboard isn't working they will then move them around and they seem to get lost of damaged (bloody kids)

Does anyone know of a way to reset the USB ports to see if it will detect the keyboard?
maybe i disable the drivers for the ports and then re-enable?
or a way or resetting SMC via command as doing it manually on the keyboard is not an option when you have hundreds of computers to look after,

Looking in logs will be hard as i have no idea when it happens to the device ( after wake up/ after turning on?)

Any more diagnostics that i should look into?

Thank you


Valued Contributor

Hi, Had the same issues.

If you get the keyboard extension cable and use that, The issue seems to be a power one.
I found it documented.
Since using the extensions on opur keyboards, the issues have ceased.
cheers n G'luck!


Thanks @kerouak So do you think that its an issue with it pushing too much power down the cable?
i know there is an issue with macbook airs and the iPad carts where you USB is power restricted so you need to enter in

sudo nvram usb-options="%01%00%00%00”

This then pushed more power down the USB port.
I wonder if i can lower the power amount for the ports.