My Mac won't connect to Jamf admin services

kjubus
New Contributor

Hi,

I have 3 Macs in my environment right now. 1 test device, 2 sort-of administration devices. I have all the JAMF running on one of those, but I need to move them to another one. So I installed JAMF Pro, I wanted to run Jamf Admin and after I enter credentials, it runs for some time and then I get an error:

8be3dace976e484dadc7220519318122

What is interesting is that I cannot access Jamfcloud from safari on the same computer. Other computer on the same network have no problem. I tried a different network as well and it didn't work. What can be wrong?

1 ACCEPTED SOLUTION

diradmin
Contributor II

@mainelysteve "You'll have to trash the preferences file ~/Library/Preferences/com.jamfsoftware.admin.plist to fix that." -- this is incorrect. When launching Jamf Admin, press down and hold OPTION (ALT if Windows keyboard). This will cause the application to re-prompt for the URL. This works across all Jamf Pro applications which communicate with the webapp.

View solution in original post

15 REPLIES 15

diradmin
Contributor II

@kjubus Have you escalated to Jamf Support?

hdsreid
Contributor III

is the computer enrolled? it could be missing the trusted JSS Root CA

diradmin
Contributor II

@hdsreid Different error for that:

The certificate for this server is invalid. You might be connecting to a server that is pretending to be "https:", which could put your confidential information at risk. Would you like to connect to the server anyway?

mainelysteve
Valued Contributor

The message on that screenshot is the clue to me. The port number shouldn't be entered if you're using jamfcloud. Try removing the :8443 from the end of your url so that it reads https://instancehere.jamfcloud.com.

diradmin
Contributor II

@mainelysteve "You'll have to trash the preferences file ~/Library/Preferences/com.jamfsoftware.admin.plist to fix that." -- this is incorrect. When launching Jamf Admin, press down and hold OPTION (ALT if Windows keyboard). This will cause the application to re-prompt for the URL. This works across all Jamf Pro applications which communicate with the webapp.

View solution in original post

mainelysteve
Valued Contributor

@diradmin Learn something new everyday. Thanks for that.

gskibum
Contributor III

@mainelysteve I manage 7 JSSs and starting a few months ago I began to have to do the option key thing all the time.

The utility SwitchJSS stopped working for me.

kjubus
New Contributor

@diradmin seems to resolve the issue. I might have been entering the address without "https" yesterday, but used it today and worked with first try. Both on safari and jamf admin.

sdagley
Honored Contributor II

@gskibum Jamf Pro Switcher works for me to switch between multiple JSS instances.

BVTMark
New Contributor III

Wow, I had the same problem this morning. Thanks!

gskibum
Contributor III

@sdagley Thank you for that tip. Will start using right away,

alex_cormier
New Contributor

@diradmin do you know if there is a way to script that so that you can deploy via policy? I've been able to change the url to the JAMF server to it doesn't have :8443 doing a manual install, but am looking to automate for others.

Thanks!

diradmin
Contributor II

@alex.cormier Yes; there is a PLIST file that may be updated via shell script with the modified URL.

Felix_Chrono24
New Contributor II

Can't login to JamF admin anymore. It's still hanging in the screen you can see in the attached image.

1a188ff48bf14bebb8fdfcd9b6060176

I can open Composer and JamF Remote. If I type a wrong password JamF Admin recognize this. I can open the webinterface of JamF.

Anyone knows what to do?

Thank you.

Best Regards
Felix

Felix_Chrono24
New Contributor II

Okay, I can connect with a catalina iMac. is this maybe a Big Sur issue?