MySides - Can only run locally

ktaylor25
New Contributor II

Hello,

I manage a handful of labs. I am trying to use MySides to configure the Finder Sidebar to be basically empty. I installed the MySides binary on my target machines. When I run "mysides remove all" in terminal on the local machine, it works exactly as expected.. all sidebar items disappear. But if I run that same command via Casper Remote, or with a policy, it never works. I also tried saving the command as an executable script on the local machine, and calling that with a policy, but it still doesn't work - but if I launch the script on the local machine by double clicking, it works just fine. I am still a little bit of a novice with this sort of thing. Am I missing something? Is there a better way to do this?

Thanks

1 ACCEPTED SOLUTION

sdagley
Honored Contributor III

@ktaylor25 When run from a policy your script runs as root, not as the logged in user. See this post for an example of running something as the logged in user: Running a "brew install" command as the current logged in user? (or search Jamf Nation, there's lots of other examples)

View solution in original post

2 REPLIES 2

sdagley
Honored Contributor III

@ktaylor25 When run from a policy your script runs as root, not as the logged in user. See this post for an example of running something as the logged in user: Running a "brew install" command as the current logged in user? (or search Jamf Nation, there's lots of other examples)

ktaylor25
New Contributor II

@sdagley Thanks for pointing me in the right direction. It's working now!