Notifications: User Interaction

sinergi
New Contributor III

Hiya,

I have been trying to get this to work without success, it looks like it should just work out of the box but sadly I can't get it to.

I have written some default text into the 'Start' and 'Complete' message boxes, and I have made sure that the 'Management Action' is enabled in Notifications.

Any suggestions?

5 REPLIES 5

waderobson
New Contributor III
New Contributor III

I just tested on my system and had no problems. I created a policy with a custom trigger(test) and scoped to all. Put the messages in and called the policy from the command line with the custom trigger and the verbose option.
sudo jamf policy -trigger test -verbose

The messages worked and this is what was at the end of the run. You might get some clues there if you run it.

verbose: The Management Framework Settings are up to date. verbose: Found 1 matching policies. verbose: Removing any cached policies for this trigger. verbose: Parsing servers... verbose: Parsing Policy TEst Notifcation (32)... verbose: Parsing Policy TEst Notifcation (32)...

could try sudo jamf manage

sinergi
New Contributor III

Thanks @waderobson, I can see how this works if I manually type 'jamf policy' but this doesn't work via self service. I created a maintenance policy and made it available in the self service so that we can give the users some flexibility in pulling down policies. For some reason manually running 'jamf policy' via terminal works but selecting the script from self service doesn't.

Also, when applications being installed via self service it also doesn't work. :(

waderobson
New Contributor III
New Contributor III

I would go through the steps here https://jamfnation.jamfsoftware.com/article.html?id=188

Make sure that the management account is 100% since self service relies on that. Then I'd check to see whats going in the jamf.log on the machine(/var/log/jamf.log) and whats showing up in the policy logs on the JSS and see if anything is sticking out there.

sinergi
New Contributor III

I had a quick read and the information is all sound my end. Can you tell me if installing applications via self service gives you a notification for start and complete?

I just find it odd that the application installs fine but no notifications appear. If I change the trigger to -re-occurring and execution frequency then notifications appear.

waderobson
New Contributor III
New Contributor III

Well I'll be darned! It don't work... So I presume this is because self service is user initiated so they'd know something is about to run.

You could use a script before and after to call the pop-up with your message.
check this https://jamfnation.jamfsoftware.com/featureRequest.html?id=1869