Packaging Maya 2022

skypointer
New Contributor II

Hi all, I'm wondering if anyone has had success in packaging Maya 2022 with a non-network server license key, which our institution is able to put on 1200 machines. I tried referencing this post, but havent been able to successfully deploy the program with my modifications. Any help would be appreciated. Thank you.

50 REPLIES 50

jonw
Contributor

@kwoodard Thanks!  Yep the '000000000000' should be just like that.  Nothing to replace.  If you run the 'legit' license command it produces exactly this as well, no idea why, but it needs to be that way.  I want to say Arnold comes down with the Maya install, but I wasn't watching closely.  Here's what I see after install:

 

/Applications/Autodesk/Arnold/mtoa/2023/blah...blah

 

 That said, I did pull down a standalone 'Autodesk MtoA-5.1.3.2-darwin-2023.pkg' as well, but didn't install it.  The pkg contents appear to be the same as what comes with Maya.

kwoodard
Contributor III

Awesome! Thank you @jonw !

One last question, it seems that we have a server license for Maya and AutoCAD, but use a serial number for Mudbox. How would I modify the code to use the serial number over the server?

jonw
Contributor

That's a great question! ... I have no idea 😉 
Though this should be a good place to start:
https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Use-In...
I'm in higher education, so luckily we just use the free education network licenses.  If an instructor wants an 'offline'  version we have them create their own account to deal with annual license verifications themselves.  They almost always opt to just use the network license.

jonw
Contributor

Actually now that I look closer you're probably better off using the 'legit' register command.  There's a flag for a serial number --sn and I'm guessing your --lm for MudBox would be USER or STANDALONE

Install one of the apps, then check this out for details:

 

/Library/Application\ Support/Autodesk/AdskLicensing/Current/helper/AdskLicensingInstHelper register --help

 

Good luck!


kwoodard
Contributor III

OK, I am stuck... The above scripts work great for a network licensing server setup... For the life of me I cannot figure out how to do a serial number setup. On our campus, we have a serial number license for Mudbox. I have tried using the following, but I get an error: "flag provided but not defined: -sn"

 

licenseFunction2 ()
{
	licensePath="/Library/Application Support/Autodesk/AdskLicensingService/${productKey}_${year}.0.0.F"
	/bin/mkdir -p "${licensePath}"
	/usr/bin/touch "${licensePath}/licpath.lic"
	#/bin/echo "SERVER ${networkServer} 000000000000" > "${licensePath}/licpath.lic"
	#/bin/echo "USE_SERVER" >> "${licensePath}/licpath.lic"
	
	/Library/Application\ Support/Autodesk/AdskLicensing/Current/helper/AdskLicensingInstHelper change --pk "498O1" --pv "2023.0.0.F" --sn "xxx-xxxxxxxx" --lm STANDALONE
}

 

 I commented out the server stuff since our Mudbox uses a serial...Lord knows why. 

I talked the guy that manages our server license for Autodesk to add Mudbox to the license server... Now everything works great. Thanks @jonw , your script is awesome!

Anyone know how to suppress the two dialog boxes that show up when the app starts (mainly Maya and CAD)? My stuff from 2018 doesn't seem to be the case anymore.

Medo
New Contributor

I tried using @jonw 's script, but I seem to be running into an issue where Maya doesn't install and I believe it rolls everything back. Not sure where to check exactly as to what is happening. I made a new package with the --silent removed and the Install worked, but obviously had to click through all the menus. Does anyone have any idea as to what might be causing the install to fail? Should the postinstall script be in Composer or Jamf?

Thanks!

 

The summary log in the macos consolde shows this.

 

Expand

******************** Install Summary ********************

Bundle: Autodesk Maya 2023

Installation Failure in Bundle: Autodesk Maya 2023
Application Name : Autodesk Maya 2023
Package Name : Maya AdLM Configuration Files
Error code : 10
Please explore possible solution from: https://knowledge.autodesk.com/search?knowledgeSource=Technical%20Support&sort=score&page=1&cg=Troub...
Package Name : Autodesk Single Sign On Component MAC
Error code : 10
Please explore possible solution from: https://knowledge.autodesk.com/search?knowledgeSource=Technical%20Support&sort=score&page=1&cg=Troub...
Package Name : Autodesk Licensing Installer 1.0
Error code : 10
Please explore possible solution from: https://knowledge.autodesk.com/search?knowledgeSource=Technical%20Support&sort=score&page=1&cg=Troub...
**************************** End ***************************

 

@Medo Funny timing, I'm actually working on Autodesk updates this week.

I can confirm my script worked without issue a few weeks ago on a dozen Intel iMacs with macOS 13.1 using the same 2023 pkg's I've used since July.  

BUT, just yesterday I had Maya fail on a fresh install as well!  Kicking the licensing service, fully removing & re-installing worked fine on the 2nd round.  Go figure.

I've noticed the install app does perform a curl to Autodesk during installation, I'm wonder if a failed network connection is the culprit?  Just a thought.

btw, here's my removal script, I take no responsibility for its use, it needs some cleanup, please use with care.  My policy always runs this prior to an install/re-install.

#!/bin/bash

### Quick & dirty Autodesk removal
### last updated 2022.07.15 @JonW

### Remove Autodesk (ALL apps & licenses prior and current, note some files/directories may no longer be present)
### CAUTION!! /Library/Application\ Support/FLEXnet\ Publisher/Service is shared with Movie Magic & potentially others (MM dirs are: 11.16.4 & 11.8.0). Remove with care!


### Stop licensing service
launchctl bootout system /Library/LaunchDaemons/com.autodesk.AdskLicensingService.plist
launchctl bootout system /Library/LaunchDaemons/com.autodesk.adskaccessservicehost.plist

### Remove
rm -rf /Library/Application\ Support/Autodesk/AdskLicensing
pkgutil --forget com.autodesk.AdskLicensing

rm -rf /Applications/Allegorithmic
rm -rf /Applications/Autodesk
rm -rf /Applications/solidangle     
rm -rf /Applications/Substance
rm -rf /Library/Application\ Support/Autodesk
rm -rf /Library/Application\ Support/FLEXnet\ Publisher/Service/11.13.1
rm -rf /Library/Application\ Support/FLEXnet\ Publisher/Service/11.14.1
rm -rf /Library/Application\ Support/FLEXnet\ Publisher/Service/11.16.2
rm -rf /Library/Application\ Support/FLEXnet\ Publisher/Service/11.17.0
rm -rf /Library/Fonts/Artifakt*
rm -rf /Library/Frameworks/Adlm.framework
rm -rf /Library/LaunchDaemons/com.autodesk*
rm -rf /Library/Management/lab_sync/Library/Application\ Support/Autodesk
rm -rf /Library/Preferences/.com.flexnetlicensing
rm -rf /Library/Preferences/FLEXnet\ Publisher/.acadplaceholder
rm -rf /Library/Preferences/com.autodesk*
rm -rf /Users/Shared/Autodesk
rm -rf /private/var/db/receipts/autodesk*
rm -rf /private/var/db/receipts/com.allegorithmic*
rm -rf /private/var/db/receipts/com.autodesk*
rm -rf /private/var/db/receipts/com.solidangle*
rm -rf /private/var/flexlm
rm -rf /Applications/Autodesk

pkgutil --forget com.autodesk.*
pkgutil --pkgs | grep -i autodesk | xargs -n1 pkgutil --forget

echo "Autodesk has been removed"

exit 0

 

sorry, duplicate reply

Medo
New Contributor

Thanks for the update. I ended up removing the script from Composer and adding it to Jamf. Then I added the the script to the policy that had the Composer package. That seems to have fixed the issue for me. Deployed the policy successfully to 30 M1 iMacs. Maybe a permission issue with whatever the installer downloads when it runs?!

 

On a side note, do you have a solution to automate the privacy/data collection popup on first launch or do you just run it once on all computers?

 

Thanks for sharing your script.

jonw
Contributor

No problem!  And yep, I would expect the script to fail as part of the Composer built pkg.

I get around the privacy/data collection popup by deploying this directory & json files (grabbed from an already agreed login) to all user accounts prior to first launch.  I don't recall if I made any edits to the files, you might want to take a look & test/edit for your environment.

 

.Screen Shot 2023-01-12 at 1.23.53 PM.png