Printing via Jamf Deployed Printer-Prompts for Authentication

lmrosbro
New Contributor II

Hello. We are transitioning from Munki to Jamf. Historically we used the Printer pkg info Wizard by Tim Schutt and Vaughn Miller, deploy via Munki and NoMad would would handle the authentication for the printers. We are now using Jamf Pro Admin to harvest the printers and deploy them via policy, still utilizing NoMad. The problem is, now our users are being prompted for authentication when the printer is deployed via Jamf. As a test, I added the printer manually and NoMad handles the auth and the user is not prompted. What changes when the printer is harvested by Jamf Admin?

Thanks for any insight.

 

 

4 REPLIES 4

ljcacioppo
Contributor III
Contributor III

You might need to run a command to force kerberos authentication on the printer, so it uses the kerberos ticket from nomad:

sudo lpadmin -p [printer] -o auth-info-required=negotiate

lmrosbro
New Contributor II

Thank you for the reply! OK...so I am aware of this setting in lpadmin, however I didn't want to have to do this for every printer and when I add it manually, this isn't necessary and Nomad handles the auth and I can print without being prompted. Only when the printer is deployed via Jamf this becomes an issue. What's different when Jamf harvests the printers?  And am I to assume the "cupsctl DefaultAuthType=Negotiate" does not work for a global setting?

 

ooshnoo
Valued Contributor

This is how I fixed it just this past week.  Simply add the script above to the file and processes payload in your policy or configure it as a script that runs "after."  Kind of a no-brainer if you want it to work.

lmrosbro
New Contributor II

Thank you both. I guess that's what I'll have to do!