Problems with Self Service click to install links Jamf 10


I just learned that several of my policies that are designed to, essentially, trigger another Self Service policy (for the purpose of their being a visual progress bar for the end user) no longer work since upgrading to Jamf 10. I used to do something like this, which worked great within my scripts:

su $USERNAME -c 'open selfservice://product=123'

With Jamf 10 I tried modifying it to this instead:

su $USERNAME -c 'open jamfselfservice://content?entity=policy&id=123&action=execute'

Although Self Service opens, it seems to do the initial "refreshing content" thing but then nothing else - let alone take me to my policy and run it.

Any ideas? I've tried some stuff with AppleScript but am getting errors and causing Self Service to crash for some reason (possibly because I rename my Self Service app to something else but do not manually deploy it).



Contributor II

Same here ^^ - I asked support if there was a way to do this and they just said "No".

So the question is when you just do a click on the link what command is that sending to open self service with said policy

open jamfselfservice://content?entity=policy&id=x&action=view - like you said just opens self service app and nothing else.

Contributor II

Has anyone had any success with these links launching in Chrome? They work and launch in Safari without an issue.