Pushing Proxies using Configuration Profiles in JAMF

aprakash
New Contributor

Using Configuration Profiles option in JAMF i had setup HTTP/HTTPS Proxies.Distribution method was "Install Automatically".
9c53867977764d34b090c7bd1ba637c7

In Scope had added the target machine to which these Proxies should be applied
33c82b5e801b400696f9a08358ce07a5

In Proxies option enabled "Enable Web Proxy (HTTP)" and " provided Hostname or IP address and port number for web proxy.
In Proxies option enabled "Enable Secure Web Proxy (HTTPS)" and provided
Hostname or IP address and port number for secure web proxy.
After this saved the Proxies.Checked and verified in logs and found that the Proxies was pushed automatically.
f1006ac0490544f7a3f249dff0952d33

As per JAMF logs Proxies values were pushed successfully and automatically to target machine.In target machine went to Network--->Advanced--->Proxies to check if the values were pushed or not.Values were not being reflected there.

Can some please provide some thoughts and inputs on this.The Proxies section under Network--->Advanced should show the updated values which have been pushed.Nothing was shown there and the even after successful operation.Internet became unavailable on target machine after this.

From Terminal tried checking all networksetup using "networksetup -listallnetworkservices" command.Entries which have been pushed through JAMF is not shown.Please help me out on this front as i am not able to proceed further.Thanks in advance.

3 REPLIES 3

lennon_moody
New Contributor

I have configured a proxy configuration profile this morning in the exact same way and I am getting the same results.

Mark_Lamont
New Contributor II

@aprakash did you ever get any more info on this? i have the same issue a year later

lennon_moody
New Contributor

I was experiencing this issues and have since discovered that the proxy settings are being applied. Rather than being applied in System Preferences > Network they are being applied by a com.apple.SystemConfiguration.plist in 'localdrive/Library/Managed Preferences/'.

Hope that helps