QuickAdd enrollment failure

Contributor III

Trying to enrol laptops with the QuickAdd.pkg we are getting this error even when using the terminal command to install the package.

FHSALZ1500:~ hitadmin$ sudo installer -pkg ~/Downloads/QuickAdd.pkg -tgt / -verboseR
installer: Package name is QuickAdd
installer: Installing at base path /
installer:PHASE:Preparing for installation…
installer:PHASE:Preparing the disk…
installer:PHASE:Preparing QuickAdd…
installer:PHASE:Waiting for other installations to complete…
installer:PHASE:Configuring the installation…
installer:PHASE:Writing files…
installer:PHASE:Running package scripts…
installer:PHASE:Running package scripts…
installer:PHASE:Running package scripts…
installer:PHASE:Running package scripts…
installer:PHASE:Running package scripts…
installer:PHASE:Validating packages…
installer: The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)
FHSALZ1500:~ hitadmin$

Any ideas as to what to do now?


New Contributor III

I had a similar error but I'm not sure if you are in the same scenario. For me, this was happening because the client couldn't connect to the portal/server. for enrollment You could just open up safari and try to connect to the site to check connectivity. what the package does is, it connects to the site and enrolls using the already embedded credentials.So if you can't connect, it comes up with the above mentioned error. Yes, the log is a bit misleading or lacks key information. My issue was that, my client couldn't reach the server hosting JSS.
P.S- Initially I had few random issues enrolling Mountain Lion to JSS but it seems to be fine now.

Contributor III

Thanks Aruja,
Is there anyway from the terminal command to know what the JAMF binary is looking for? Maybe a conf file that can be checked / changed to fix any differences?

New Contributor III

Could you please try sudo jamf enroll -prompt -verbose I did this to see what exactly the quickadd package was doing at each installation step.

Is this quickadd package created from Recon?
Is the package allowed for multiple client enrollment?

Contributor III

Aruja, the package is from the Self-service web site. how do you enable multiple client enrollment ? I did try using Recon but had the same result, strange that it has worked but not now, change in network settings (all from dhcp)? I have logged a job with JAMF to look at this. thanks for your input and will run sudo jamf enroll -prompt -verbose in the morning and let you know what the result is.

Valued Contributor

You could also verify that the time and date are correct on the client.

Contributor III

All time / dates are set by the same time server.

Contributor II

check the install.log file. looks like the quickadd might be failing on the postflight, based on the percentage in your output before you get a failure message. The package installs the jamf binary, but it is the POSTFLIGHT script that does the actual enroll.

If you create a quickadd package from recon do you get the same output? Also, try using '-target' rather than '-tgt'.

New Contributor II

Did you ever figure this out? I'm having the same issue. The enrollment inside the post-flight script of my recon quickadd is failing. I ran the post flight commands from terminal on the machine that was failing and I get this:

command: sudo /usr/sbin/jamf enroll -invitation 123456789 (edited for security) Downloading the JSS CA Certificate...
This computer was successfully enrolled to the JSS with the following device certificate: "1234-1234-1234-1234-1234"
Retrieving inventory preferences from https://server.domain.edu:443/...
Finding extension attributes...
Locating hard drive information...
Locating hardware information (Mac OS X 10.8.5)...
Locating accounts...
Locating applications...
Searching path: /Applications
Gathering application usage information...
Locating printers...
Locating software updates...
Submitting data to https://server.domain.edu:443/...
Getting management framework from the JSS...
Enforcing management framework...
Checking availability of https://server.domain.edu:443/...
The JSS is available.
Enforcing login/logout hooks...
The computer was not enrolled in MDM with the JSS. The device certificate did not install.
Enforcing scheduled tasks...
Creating launch daemon...
Creating launch agent...
Checking for policies triggered by enrollmentComplete

Contributor II

try a jamf enroll -prompt. usually works for me when other commands do not.

Also, jamf enroll -verbose might help more too


Take a look into your SSL Certificate. https://jamfnation.jamfsoftware.com/discussion.html?id=8836

New Contributor III


I had the same issue with 9.2. Recreating the SSL cert seemed to fix it.

New Contributor

Hello! I am having this issue as well, I have recreated the SSL with no change, Has anyone figured this one out?

Esteemed Contributor II

@Dyc3 Are you trying to re-enroll a Mac that already exists in your JSS, or is the failure occurring adding a new machine? If the latter, try deleting the machine from your JSS and see if running the QuickAdd then works. I experienced the problem with QuickAdd not working on machines in my JSS that needed to be re-enrolled after re-imagine, and ended up modifying a QuickAdd with a preinstall script that would delete the machine from the JSS.

Valued Contributor II

I would take a look at clearing out the user/location data and trying to enroll again. We definitely ran into PI-002950 on our of our Jamf instances, and needed to put a API script to clear user/location data into our Imaging config in order for re-enrollment to work 100%.

Valued Contributor

Global Management > JSS URL ..

Remove the entry for: JSS URL for Enrollment Using Built-in SCEP and iPCU

Try again!

Worked for me