Self Service Blankness - solved

Not applicable

OK - got it solved. We were not entering the fully qualified domain name to the master distribution server in Casper Imaging when we (and by WE I mean ME) launched Imaging. That means it wrote the server name to /private/etc/jamf.conf as an unqualified name. This caused Self Service to not work so good as it could not go to the unqualified name of the server.

Since we have a bunch of techs across the US who will be doing reimages, and I can't be 100% sure they will enter the fully qualified domain name at Casper imaging's launch, JAMF helped me to create a policy to run once at startup and run the following command that will update the jamf.conf file with the proper, fully qualified server name:

/usr/sbin/jamf createConf -server -ssl -target /

I created that policy, rebooted one of the computers I was having problems with and bingo - Self Service was working again.

So the lesson is - always use a fully qualified domain name when you get the chance.

OK - time for lunch!

Rich Barron