Server issue

New Contributor III

We've had and outage on our virtualized environment which includes my instance of the JSS. They've gotten everything restarted, but now that my server is back up I'm noticing some problems with the JSS.

If I go to search the computers or mobile devices, I'm not seeing all the data in the table. The table is missing OS, Model, Serial Number, Ram, HD is listing n/a, and % Full is listing 0% for all records. If I then select a specific record, I get this at the top of the record:

Lookup management command: java.sql.SQLException: com.jamfsoftware.HTTPRequestActions.ViewComputer.process: SQLException from executeQuery: java.sql.SQLException: Incorrect key file for table './jamfsoftware/mobile_device_management_commands.MYI'; try to repair it

I then tried to go to Settings-Database/Web Application Health which gives me the following:

org.apache.jasper.JasperException: An exception occurred processing JSP page /WEB-INF/jsp/nav_main.jsp at line 137


135: <%=JSSUtils.encodeHTML(session.getAttribute("lastError"))%>
136: 137: 138: 139: 140:


I just tried to restart Tomcat, but received the following:

$ sudo /etc/init.d/jamf.tomcat7 restart
Restarting Tomcat 7...
bash: /usr/local/jss/tomcat/logs/tomcatinit.log: Read-only file system
Forcing Tomcat stop...
bash: /usr/local/jss/tomcat/logs/tomcatinit.log: Read-only file system
Unable to stop Tomcat!

We're running JSSv 8.52 on Linux/Ubuntu. I sent an email to Support, but figured I'd cover all bases...


New Contributor II

Sounds like your mysql database has some corrupted tables in it. Your best bet would probably be to restore your most recent backup from before the outage and see if it resolves it.

Honored Contributor

Before that I'd run the health check. Settings -> Database/Web Application Health

Legendary Contributor III
Before that I'd run the health check. Settings -> Database/Web Application Health

Jared, sounds like she already attempted that and got errors in the JSS.

I'd say you definitely have a corrupt db that's going to either need to be restored, or perhaps support has some tricks up their sleeve to get this working again. I hope you had a recent backup.

Honored Contributor

Ah yes. OP, do you have ssh access to the machine?

New Contributor III

Well, it turned out to be a larger issue. When our VM went down, the systems that took the biggest hit was the Linux boxes. They all came up as read-only. On the JSS, I couldn't do anything. Going into any of the Database/Web Application Health options gave me the errors I posted above. I was able to ssh into the box, but I couldn't run any commands.

We ended up restoring from a snapshot we had from the weekend. Once that was in place I was able to run a database check and repair from the JSS console which showed everything to be healthy.

I feel sorry for one of my colleagues dealing with the same issue for a PGP server. It's been an awesome start to the week.