Shared iPad autolock time

RyanSK
New Contributor II

Does anyone know of a way to make the Autolock time longer than default on a shared iPad deployment?

Students are complaining that it locks the device too quickly when they are referencing it as a textbook.

1 ACCEPTED SOLUTION

bfrench
Contributor II

If the iPads are set as true Shared iPads you can not change when they lock but you can change the Lock Grace Period in Remote Commands.dc0b74e69d51470c9e5d43929f17514c

View solution in original post

11 REPLIES 11

belldesean
New Contributor III

78269384d84141009b287b2d05ca0d6e

bfrench
Contributor II

If the iPads are set as true Shared iPads you can not change when they lock but you can change the Lock Grace Period in Remote Commands.dc0b74e69d51470c9e5d43929f17514c

View solution in original post

m_green
New Contributor III

@bfrench

Wow, I can't tell you how many times I've looked right at this and it never dawned on me that the solution to our problem was right there. Thanks for sharing your screenshot. I interpreted the usage differently and thus never used it.

kcc
New Contributor

This isn't even working for me. I set it to 5 minutes and the devices still lock themselves after 2 minutes and then I need to enter the password again. How is this such a hard setting for Apple to get right? We have a bunch of primary school students that want the Shared iPad next to them while they paint/draw from something displayed on screen.

sdrake
New Contributor III

This feature does not work. After choosing a new grace period, the page spins/loads for several minutes and never makes any change.

Rattomlin
New Contributor III

This does not work and there is a feature request to make it happen.

gmorgan
New Contributor III

Just to bring this more current, I recently tried this. Remote commands still didn't seem to work so I tried a config profile with the passcode payload. All seems to be going according to plan (the config profile even shows up in the device's scope under management) until I received this error: 'The payload type “com.apple.mobiledevice.passwordpolicy” is not permitted in multi-user mode'. So.....still a no go.

Rattomlin
New Contributor III

This worked for me as it was implemented with Jamf 10.11 I believe.

user-NmrcfQRdqE
New Contributor

Does anyone know if this has been solved yet? I have a heap of shared iPads and I'm still unable to change to Auto-Lock time. It defaults to 2 mins and the setting is not shown in the iPad's Settings to change it.

dtmille2
Contributor II

According this Apple article, the auto lock time should be able to be extended up to 5 minutes. However, I am not able to get this command to work either. Anyone able to change the default screen lock time for Shared iPads in their environment, or is this feature still not working?

https://support.apple.com/guide/mdm/passcode-payload-settings-mdm4d6a472a/1/web/1.0

 

dtmille2
Contributor II

Update to this: I opened a support ticket with Jamf and after working with a couple of support personnel I was told that they are reopening a Product Issue for this behavior. I understand that they thought this behavior was resolved with a PI that was opened, but it appears that it is not.

Interestingly, and Apple engineer I spoke with seemed to think that a command to alter screen lock time on an Shared iPad should not work at all based upon the support documentation he was seeing. I wondered out loud how this command would have gotten into Jamf Pro in the first place if it had not been supported by Apple?

Citrix end point management for iPad also offers the command:

https://docs.citrix.com/en-us/citrix-endpoint-management/policies/passcode-lock-grace-period.html