SMTP Server

Quan_nong
Contributor

Hi All

Does anyone have trouble setting up their smtp server with gmail? I assume I'm using all the correct settings, but when i come to test the connection I get unable to connect to smtp server ( tested the username and password to login directly to gmail and they work fine )

url - smtp.gmail.com port - 465
protocal - SSL

10 REPLIES 10

claudiogardini
Contributor

You probably need to "allow less secure apps" https://support.google.com/accounts/answer/6010255?hl=en

Quan_nong
Contributor

Tried that and still not able to connect and I also tried using outlook.com smtp server and got the same error

brj
New Contributor
New Contributor

I quickly tried this today using jamf cloud and could not get it work. I also tried an on prem server with the same gmail account/details and it worked fine. Are you using jamf cloud ? If so, we may need to contact jamf support.

Quan_nong
Contributor

I'm using Jamfcloud. I got it working with a normal Gmail account, but it doesnt seem to like a google business account ( If with all the added security it has like MFA )

richardPF
New Contributor

I don't know if you found a solution, but I got it working with the below settings with our company business Google account.
8a33c51cc834430fa47cf682a1cffcf9

stephenb
New Contributor III

You'll need to turn on "Less Secure Apps" within your Gmail account that you're connecting.

https://support.google.com/accounts/answer/6010255?hl=en

dbradprice
New Contributor II

Note that Less Secure will be deprecated soon.
https://gsuiteupdates.googleblog.com/2019/12/less-secure-apps-oauth-google-username-password-incorrect.html

arnaud_mombrial
New Contributor

Hi,

what I did to successfully configure a GSuite Business account in a 10.20 Jamf Pro Instance :

In Jamf Pro Instance : https://<my-custom-url>:8443/smtpServer.html

Server and Port : smtp.gmail.com 465
Encryption : SSL
Connection Timeout : 30
Sender Display Name : Jamf Pro Server
Sender email address : prefix>@<custom-domain-name-managed-in-gsuite
Requires authentication : Yes
Username : prefix>@<custom-domain-name-managed-in-gsuite
Password : <APP PASSWORD>

It means that I activated 2-Steps Verification for prefix>@<custom-domain-name-managed-in-gsuite email, then I created an App Password specifically for Jamf Pro.

Security settings for GSuite can be found here : https://myaccount.google.com/security
App password can be configured here : https://myaccount.google.com/apppasswords (only works after 2-steps enabled)

PatrickD
Contributor II

Following

dbrady
New Contributor

This worked for me...arnaud_mombrial
Thanks!