(some) Mobile Apps not installing (Auto install or Self Service) (for some clients)

Valued Contributor

I'm using ASM and VPP.

I have a number of devices in our environment where they refuse to install applications. Sometimes it's a single app that does not install and sometimes it's all apps for the device.

On the Jamf Pro console I will see Install command completed yet when I update the device record the app does not show as installed.

At times I also see install command Pending - Application is not available to install.

I have plenty of licenses available for the app and devices are on different networks (our network, home network, hotspot, ...)

device syslog gives errors:
appstored (app info) Installing vpp application with evid: (null)
appstored (app info) Complete for evid: (null) changeType: 3 success: 1
Things I've tried so far:
1. Cancel the command, exclude the app from scope for the device
2. Application scope: Add the client to exclusion list
2. Device Management tab: Update Inventory and Send blank push
3. Wait for the device record to update
4. Application scope: Remove the app from scope exclusion
5. Device Management tab: Update Inventory and Send blank push

Global Settings>VPP Accounts>Account>Content>Select Category, locate the app from the list and select Refresh.

I have enabled debug logs, enabled VPP logging on the server and sent those to support.
I have sent a sysdiagnose log from a mobile client.

Support says it's an Apple issue.
Any other tips?


New Contributor II

First day setting up Jamf Pro and ran into this issue with my first device. Device > Management Commands > Update Inventory button immediately installed two apps that were missing after pre-stage enrollment. I tried the previous mentioned solutions so it may be a combination of steps.

New Contributor III

I am so glad someone else is seeing this also. We have been fighting it for a while. I will keep sending a blank push to get them to take. I have to go into each device and push the apps. It takes 30 minutes for each device to install everything and that is because I am doing the blank push. This is pushing and going to history and back again to management commands. I will go back and forth to get these installed. Not sure if this helps but it does seem to. It is almost like it is timing out. When you are trying to a room at a time this is very time-consuming. We have had an issue with Self-service for quite some time so we just removed it to eliminate an instance because it is not working.

New Contributor

Anyone still having this issue? I have a few devices doing the same thing, just wondering if there was ever a resolution.

Valued Contributor

I've opened a support case today and received:

... PI-008633. The current workaround is to wipe and re-enroll...

So at least they are aware of it.

New Contributor III

Just about to submit a ticket for our instance as well, with none of the earlier suggestions in this thread seeming to provide a consistent solution to installing or updating apps. Everything else seems to be working fine though.

Valued Contributor

We have an app that is set to auto install and may have stumbled upon a workaround.
I'm trying to gather more details.

I don't know (yet) if the device is experiencing the issue as above (and I don't have a physical access to such device).
The tech was able to use spotlight/search for the app and click on that. Then they were presented with a message that the app is not installed.
The icon for the app was showing but it was grayed out. As if the install was on pause.

I thought I'd share this in case someone may have access to such device and can try it in their environment.

New Contributor III

It's starting to look like in our situation, it's tied to particular apps (one example in our case is Adobe Acrobat Reader), and clearing the affected apps will allow all other apps in the queue to install.

In this case, I do recall a similar situation a couple of years ago where a couple of recently updated VPP apps started to do this. We might be seeing the same thing occurring here.

Valued Contributor

I'm not 100% sure if the device we had access to today was experiencing this problem.

We did see the app icon displayed (grayed out) with the words: Waiting
Selected the app and saw the following message:

Unable to Install "appnamehere"
You must purchase this app to install it.
View in App Store

and selected OK, then deleted the app on the glass,
then opened Self Service and install.

I know this is not a solution to all cases, as I have seen no pending apps waiting, on some devices yet apps would not install, but something to try.

New Contributor III


This sounds like an issue a heap of admins were encountering had a while back.

Hopefully the thread might point you in right direction.


New Contributor III

We have the same problem.
Seemingly random iPads wouldn't enroll.
We narrowed it down to a user > scoping > particular app.

When that particular app is scope for that iPad - the enrollment will fail.
Its "fairly" easy to see the possible candidates by going to the device > Management History.
You will probably see one or more apps and a few management commands pending.

Solution #1 Unscope the app(s) from the particular iPad(s)
Cancel the management command(s)
Send blank push.
The rest of the commands will go through and you'll end up with 0 (zero) pending commands - won't fix the app though...

Solution #2 (more permanent) - recently discovered - this solution will also fix the app.
Choose another location for the app under the "Managed Distribution" tab.
If yo do not have another location - delete the app and "buy" it again.

Feel free to comment...

New Contributor II

Our iPads experienced the exact same as RLR (please refer to that picture). The only work-around was to manually identify missing apps (teachers went one by one through their iPads - EXCRUCIATING!). EXCLUDE the iPad "installing" from that APP ASSIGNMENT. Update Inventory, Restart, then UN-EXCLUDE - then - the app may install. As for available space or iPad system settings. All iPads are G7 (the same make, model, size) - and have plenty of space available.

New Contributor III

I have found it will say 'pending' for all many apps until a final 'Update Inventory' is sent to them. I did this one at a time to be sure this was what was missing. This has been going on for some time now. Wondering if we are going to get a fix in a future update?

New Contributor II

I discovered changing the category back to "None" allowed the apps to install.

New Contributor II

I have the same issue.  45 new iPads and 1/2 have the apps in a pending state and Management Status is "Installing".  These were all fresh out of the box iOS 14.6.  This will be a pain if I have to wipe them just to get them working as they are three time zones away.  Is there any solutions on this site?

After you install the apps to get them to complete you will need to do an inventory update. That is what they tell me even though they say it is fixed. The inventory update needs to be done right after. If you wait a day sometimes they do not take.

The challenge with doing and inventory update is that it appears for some reason the device is no longer communicating with Jamf Pro.  So the new command goes into Pending also.  I ran that on several of the devices that appears to have their apps stuck and now that command is stuck too.  It's a dilemma for sure.

I would say something has shut off your network connection or changed it to something that is not compatible. We have only one WiFi connection configured for our shared iPads. If we didn’t we couldn’t use classroom and it would be picking something else all the time. We went with 5.0 so it would not look for stronger connections. Hope this helps. I spent some time troubleshooting this myself. Very painful to reinstall and hope it does not time out or disconnect.

Are the devices able to browse the internet? And can they reach the site via Safari?

Just over the weekend, I noticed a group of devices not installing an app, and realized that our platform's APNS certificate had expired which meant the devices weren't receiving commands from Jamf anymore. Renewed the certificate and everything was all good with the apps shortly installing straight after.

It turns out that it was on our end.  Our DHCP Scope was out of valid IP addresses.  Once our numbers were successfully increased we released all of the current licenses, rebooted all the APs that were onsite and successfully re-connected each device and the Apps loaded.  Thanks you all for your input.

Valued Contributor

Is this PI-008633?