Struggling with a PUT command

Hackert
New Contributor III

Somehow JAMF is showing my teachers' Managed Apple IDs incorrectly, it is using the suffix our students have.  It gets that information from ASM, but ASM is correct and the sync isn't correcting it in JAMF.  A suggestion was made that I use a curl command to update these accounts in JAMF.  So I have tried, but so far have not been able to change anything.

I am passing credentials of an Admin account.  And the connection works, as I can run a command to get information about a user.  From that command, I am also confident I have the correct ID #. The command runs, gives no error message, but changes nothing.  I have also attempted to change the Grade, just to see if that was possible and that also did not change the account in JAMF.  Below is two renditions of the command I am running from a Windows command prompt.  Any thoughts on why this would not work?  Bad syntex?  Do I have to enable API commands somewhere in JAMF?

Thanks in advance.

curl -X PUT -k -s -u AdminUserName:AdminPassword -d "<user><managed_apple_id>correctedAppleID</managed_apple_id></user>" "https://my.url.com/JSSResource/users/id/393"

and

curl -X PUT -H "Content-Type: text/xml" -ksu AdminUserName:AdminPassword -d "<user><managed_apple_id>correctedAppleID</managed_apple_id></user>" "https://my.url.com/JSSResource/users/id/393"

1 ACCEPTED SOLUTION

Hackert
New Contributor III

In case anyone is searching for an answer.. I did not include the port number in my URL.  You need that...

Peace.

View solution in original post

2 REPLIES 2

Hackert
New Contributor III

I should also mention that in JAMF's console, going to Users - General it shows the incorrect email address under Managed Apple ID and states that "this users Managed Apple ID does not match the Apple ID reported in ASM".  But if you click on Roster, the users Managed Apple ID shows the correct email address of the user created by ASM.

I simply found it strange that their labels on both pages are Managed Apple ID, but the entries are different.

Hackert
New Contributor III

In case anyone is searching for an answer.. I did not include the port number in my URL.  You need that...

Peace.

View solution in original post