System giving error running policy _NSConcreteURLComponents unrecognized selector sent to instance 0x7fab59c4c590

aamjohns
Contributor II

Hello,
I am troubleshooting a handful of systems that are not checking in or not successfully running policy. The system I am working on right now (10.9.5) will give the above error (_NSConcreteURLComponents unrecognized selector sent to instance 0x7fab59c4c590) when running a policy. Additionally, I have policies that are in pending state for this system and if I run sudo jamf policy on the system, it will say there are no policies to run. If I run the policy using Self-Service I get an error (non-specific) that tells me to contact support (or the administrator, I don't remember for sure).

I've tried removing jamf (sudo jamf -removeFramework) and then re-enrolling the system. I can see in the JSS the system reports the enrollment, and things look like they are ok.

This is the only system I am aware of with this specific error. Some things work like Casper Remote, but if I try to run a .pkg it will fail with the above error.

Does anyone know of a fix or what might be causing this?

Thank you,
AJ

13 REPLIES 13

cyrus_ingraham
New Contributor III

What version of Jamf are you using?

aamjohns
Contributor II

Hi,
I am on 9.98.

cyrus_ingraham
New Contributor III

Hi,

I believe you have run into a product issue (PI-003819) which resulted in all clients running 10.9.x not being able to download packages over HTTP/s. This defect has been addressed in a hotfix for 9.98 (9.98.1491860392/9.98 Hotfix 2). This is currently not released for GA (general availability) but can be obtained by contacting Jamf support. The fix will also be included in the GA 9.99 release.

aamjohns
Contributor II

Ok. Good to know. I will contact support tomorrow. Thank you for the information. AJ

tinsun
New Contributor II

@cyrus.ingraham Thanks for the heads up! I was kind of confused seeing the policy constantly running on the computer in question, until I tried pushing the pkg thru Casper Remote. Does anyone have an idea on how to fix it immediately without the hotfix?

aamjohns
Contributor II

Just an fyi, I contacted support and the hotfix is not available to us. At least when I checked last week. The only workaround is to use SMB or AFP.

cyrus_ingraham
New Contributor III

@aamjohns Sorry I was misinformed about the availability. I will get clarification on this and post an update here if there are any options besides waiting for 9.99. The workaround you mentioned is the only workaround for this.

aamjohns
Contributor II

No apologies necessary 🙂 I appreciate your responses and willingness to try and help. Thanks, AJ.

reidg
New Contributor III

I am attempting to install a package when remotely connected to a client via SSH. When I point to the http distribution point, I receive the following message:

Downloading abc_123.pkg... 2017-05-11 14:41:41.850 jamf[89656:507] -[__NSConcreteURLComponents queryItems]: unrecognized selector sent to instance 0x7fc74a7095b0 There was an error. -[__NSConcreteURLComponents queryItems]: unrecognized selector sent to instance 0x7fc74a7095b0

So, based on the workaround, I attempted to install via smb, but the package cannot be found via that method:

root# jamf install -package "abc_123.pkg" -path "smb://jss.server.com/CasperShare/Packages" -target / -showprogress Error: The package (abc_123.pkg) could not be found.

Is my syntax above correct for the smb install? Any other ideas how to get the package installed remotely?

Thanks,
Reid

mpermann
Valued Contributor II

@reidg when I try and install a package that is on a network share through the GUI I get an error message about the package not being able to be installed from a network volume. I've experienced this over AFP and SMB. I don't imagine this would work in the CLI. But I could be mistaken. I think you may need to copy the .pkg file to the local computer to say /tmp and execute the install command pointing to the local copy of the .pkg.

reidg
New Contributor III

@mpermann thanks for the idea. I was able to scp the pkg to the client and install via terminal using installer.

jmahlman
Valued Contributor

Was this resolved in 9.99+ and up? Just want to be sure that we have to upgrade our server to fix this.

eosagie
New Contributor

Can confirmation be provided that upgrading to 9.99 resolves this issue? Thanks!