TCC not working

julienvs
New Contributor III

Hi Everyone,

I’m trying to help a user with the following problem:
- Camera works in facetime
- Camera not found in any third-party app such as Skype or Zoom

I’m expecting PPPC/TCC to kick in and ask access to camera and mic but it doesnt and the list ( in sys prefs, privacy) is empty.

I tried with a new app but there is no prompt appearing asking for video and mic.

Does anyone have a clue on what could be happening? This is 10.15.3. and I've reset the PPPC/TCC requests already.

Thanks in advance,

Julien
0491fee9c9dd42cc80e521d3d8978317

1 ACCEPTED SOLUTION

julienvs
New Contributor III

Thanks guys!
What a horrible issue to troubleshoot remotely πŸ™‚

Here's what I did thanks to your advice:

  1. reboot computer while holding command + r
  2. open terminal
  3. csrutil disable
  4. reboot
  5. Sudo rm -rf ~/Library/Application Support/com.apple.TCC
  6. reboot computer while holding command + r
  7. csrutil enable
  8. reboot

Thanks again and good luck to everyone in these remote times!

Julien

View solution in original post

6 REPLIES 6

donmontalvo
Esteemed Contributor II

adamjameson
New Contributor II

Try running permissions on the account. We ran into this and it seems like fixing permissions with

sudo chown -Rv <username> /Users/<username>

and then restarting fixes the issues. You could also fix the permissions in the GUI. Here is an article that gave us the idea of using this to fix this issue.

https://superuser.com/questions/1441270/apps-dont-show-up-in-camera-and-microphone-privacy-settings-...

julienvs
New Contributor III

Hmmm ... seems it's a corrupt PPPC/TCC database. Tried to reset it but now it's even more damaged. I'll post results here.

cliftoja
New Contributor III

What I have been successfully doing is disabling SIP and then running the command 'Sudo rm -rf ~/Library/Application Support/com.apple.TCC' from the terminal and then enable SIP again. That seems to do the trick.

macmanmk
Contributor

This post really helped us resolve our TCC issues last year.

julienvs
New Contributor III

Thanks guys!
What a horrible issue to troubleshoot remotely πŸ™‚

Here's what I did thanks to your advice:

  1. reboot computer while holding command + r
  2. open terminal
  3. csrutil disable
  4. reboot
  5. Sudo rm -rf ~/Library/Application Support/com.apple.TCC
  6. reboot computer while holding command + r
  7. csrutil enable
  8. reboot

Thanks again and good luck to everyone in these remote times!

Julien

View solution in original post