Trouble customizing PPDs using the CUPS webctl in OS X 10.11 El Capitan

New Contributor

Hi All,

Apologies if this has been discussed elsewhere. I did my best to search existing threads.

In the past, when deploying printers with Casper I've used a workflow where, on a packaging computer or VM, I install the printer drivers and add the printer to OS X via the gui, then suck the printer into the JSS using casper admin.

Next I would typically use the CUPS web interface (http://localhost:631) to go and modify all the defaults that I wanted to get pushed out with the printer object (for example, default to single-sided, black and white, etc.). In the past, applying changes to defaults using the CUPS interface would modify the .ppd file in /etc/cups/ppd which i would then add as a custom ppd to the printer object in the JSS

For deployment i'd have a policy with the driver package and the printer object with the custom .ppd file. This has always worked great.

I've just been attempting to package up a printer in this manner in 10.11 and noticed that any changes to defaults made with the cups web interface no longer stick. I assume this is due to SIP not allowing the CUPS interface to modify /etc/cups/ppd/*

Has anyone been using the cupswebctl to successfully modify printer defaults in El Capitan? If so, any pointers? An alternate workflow for customizing the PPD would also be useful! Open to suggestions.

Best regards,


New Contributor

Looks like i'm not alone in doing things this way....

Looking forward to your 10.11 feedback!

Contributor III

I usually add any additional or changed CUPS defaults with a script after the printer setup, this is still working for me with my 10.11 deployment.

Example for kerberos and black & white printing:

#set kerberos printing
lpadmin -p <printer_queue_name> -o printer-op-policy=kerberos
#set default color mode to b&w
lpadmin -p <printer_queue_name> -o ColorModel=Gray

New Contributor

Well, i figured it out.... Looks like cupswebctl still does affect the ppd file in OS X 10.11. I had an issue where the printer i was modifying wasn't happy with the options i was selecting and thats why the modification of the ppd file didn't happen. In OS X 10.10 the cupswebctl threw a warning about the settings. In 10.11 there was no warning, so it just looked like it had saved my changes in the webctl.


@davidhiggs Any chance you could elaborate on this? I've been tasked with setting all of our printers to default to b&w, but they have already been deployed across many offices, so I have to do it via script. So far I have had no luck with this whatsoever.

I tried running a terminal command on my machine just to test the b&w command. It doesn't seem to have worked. Any ideas? I'd greatly appreciate any input you can provide!