trouble disabling auto-logout

scottd
New Contributor

Hello,

I have a set of computers that is set to logout after 20 minutes for students. I've had to re-allocate some of those computers elsewhere, but am having trouble disabling the auto logout setting. I've disabled that setting in the jss, but I can't seem to remove it from the computer. If I go into system preferences/security/advanced, I can uncheck the option to auto-logout, but after I close system preferences and go back in, the box is checked again. I've created a managed preference to set the global preferences to disable auto-logout (with a value of 0), but that doesn't seem to make a difference. Any suggestions?

thanks!

3 REPLIES 3

bentoms
Honored Contributor III
Honored Contributor III

@scottd are you sure it's not being set from anything else?

Also, if you reenable the setting in the JSS & set that to 0, does that work?

davidacland
Honored Contributor II
Honored Contributor II

I would check in the System Information app > Software > Managed Client to see what settings the Macs are receiving.

Also might be worth removing one from Casper (use sudo jamf removeFramework) to see if the setting is coming from the JSS or not.

emax
New Contributor III

@scottd :

Did you ever resolve this? I'm having a nearly identical problem (see https://jamfnation.jamfsoftware.com/discussion.html?id=21279 )

Any pointers appreciated.

-max