Two computers, same Hardware UUID.

Contributor II

We have a lab of older computers that we just re-imaged to 10.6.8, but after looking that lab up in the JSS, one machine wasn't showing up. So, we tried enrolling it via QuickAdd, which added just fine, but that ended up booting out another computer in the same lab. I did a little digging, and found that both computers were trying to add with the same JSS ID, so they kept kicking each other out (a la Upon further inspection, both iMacs have the same Hardware UUID, and Casper 9 now uses that as the primary identifier when enrolling a device.

I tried manually changing the UDID field for the existing machine in the JSS, then enrolling the other one, but the one whose UDID field I changed then couldn't talk to the JSS (no longer has a valid device signature). I've tried deleting both computer entries, but no dice. A re-image of one or both did nothing to change the Hardware UUID, and after copious amount of Googling and playing around on the system, I haven't been able to find if a new UUID can be generated for a machine. So much for them being unique identifiers.

Anyone see anything like this in the past, or have any sage advice to impart? Thanks!


New Contributor II

I was not going to test this on my machine for obvious reasons but maybe give this a look:

Contributor II

Hmm, looks like that uuidgen command only generates the UUID string, but doesn't actually apply it to the system. Good idea, though! I think it's kind of funny that the man page says it's "a 128-bit value guaranteed to be unique over both space and time." Can I get my money back?

Esteemed Contributor II

We had to replace a logic board on a Mac. Now it shows up twice in JSS because of the new UUID.

Not related, and probably not helpful...maybe Yhprum's law?


Valued Contributor

So if you run this command on both machines, they have the same output?

ioreg -rd1 -c IOPlatformExpertDevice | grep -E '(UUID)'

Contributor III

@donmontalvo That's happened here before, when the board was not serialized properly. Unless you have some need for the historical data you just delete the old record & move on with life. :-)

Contributor II

@calumhunter][/url I ran ```
system_profiler SPHardwareDataType | grep UUID | awk '{print $3}'
``` on both machines, but your ioreg command also results in the same output for both.

Esteemed Contributor II

@chris.kemp Yep, we deleted the stale computer after confirming that the log history wasn't needed (useless to JSS, but wanted to make sure there was no security mandate to retain the logs).

In some companies we had lazy ACMTs who didn't understand why it was important to burn in the Serial Number into the new logic board. Apple handled this repair, good to see they covered that base. :)


New Contributor III

Posting this here for the next time I forget it

If you notice that a VMware Fusion cloned VM changes the Serial Number but not the Hardware UUID, shutdown the cloned VM, look inside the .vmwarevm bundle, and delete the .nvram file. Start up the cloned VM and you will see that the Hardware UUID has updated.

This was tested on Fusion 10, YMMV on older versions.