VPP Apps will not install after upgrading to JSS 10.3

sedwards
Contributor

The upgrade went fine, but now I can't deploy any apps. I either get Install "Pending" Indefinitely or it tells me it cannot connect to itTunes Store. I've tried the following sets as per other posts:

  1. Set App to install through Self-Service, assign VPP license, hit save.
  2. Assign to specific device, hit save.
  3. After a few minutes, set to install automatically, hit save.

I've removed and re-added devices to the scope multiple times but nothing will get the app to install. I'm seeing the following error in the JSS Logs:

2018-03-27 10:55:30,547 [ERROR] [Tomcat-13 ] [StatusUpdate ] - Install Application failed for device: 'IPAD_NAME' for app ID: 290 with Error: [code=-999, desc=null]. Delaying and marking active
2 REPLIES 2

terry_jolley
New Contributor

Were you able to get this resolved? We have a similar issue. We are able to deploy free VPP apps but the one paid VPP app we need, tries and fails to install on the iPad. We do see the app in our VPP accounts and have added it via Mobile device apps.

JAMF PRO 10.3.0-t1521825567

Device management console shows following error:
Install App - Teleprompt+ 3 3.1.10 The operation couldn’t be completed. (SSErrorDomain error 141

Server logs:
2018-04-06 13:07:34,439 [ERROR] [Tomcat-8 ] [StatusUpdate ] - Install Application failed for device: 'DEVICE_name' for app ID: 48 with Error: [code=141, desc=null]. Delaying and marking active

bfrench
Contributor II

I had this issue as well - but then realized our JSS was off again by 2 minutes. Updated time and all seemed to work as expected.