Wifi Autojoin Configuration Profile

New Contributor II

Greetings all,

So we've been experiencing some issues with a configuration profile we have setup to join our "Student" SSID here in our school district.  If the iPad currently has IOS15 on it and that iPad either has the battery die or you simply reboot it.  The device will not reconnect to WIFI.  If it has anything lower that IOS15 it works every time.  We tested this on IOS14.6 and 14.7 and with multiple reboots on each of those devices and it reconnects every time.

Just wondering if anyone else is experiencing this and potentially has a fix for it.  Any help is greatly appreciated!

Thanks.....  Jesse


New Contributor III

Interesting problem.  I don't have a solution but I'm curious, does it see the Student SSID and just not connect to it, or does it not even see the network?  Will it connect to other networks?  And are you able to connect manually to it?

Yes it sees the SSID, and just won't connect.  Well it will connect if I tap on it but the issue is it prompts for the password which we of course don't give to the students.


And we have an SSID for teachers that doesn't have any config profile set to it and that reconnects every time.  So it definitely has something to do with the Configuration profile....



That's an odd one.  Have you deleted the profile and recreated it?

Yeah.  Many times.  Even created a brand new one.  We use WPA2 encryption on several different SSID's and if we apply it to any of those it does the same thing on IOS15.

But works everytime on 14.6 & 14.7  I didn't test any other versions yet....

New Contributor III

That's odd.  I haven't got any good answers, but I'll look forward to what others may share.

Contributor III

Just cycled a couple of iPads on iOS 15 a few times. One was upgraded and the other is a fresh install (restored today). Did both regular and forced shutdowns. Sorry to say, I was unable to reproduce your issue.

Have you tried wiping one of the iPads? I would also test making a configuration profile for the teacher SSID to confirm whether or not it is the configuration profile. Past that, I don't have any advice.

New Contributor II

Do you have WPA2 encryption turned on your network?  Cause thats the only way it breaks on our side.  I can connect to any other WIFI with different encryption.

Yeah we have wiped many ipads over the last few weeks.  And with all of that said.  On IOS15.2, I have it down now to where it will disconnect every time the button is pushed to turn the screen off.  It takes roughly 15secs to disconnect.


And as for the TEACHER SSID.  We tried it with that two.  We have 4 different config profiles that we have been testing.  Two are active on the ipads within our district.  One we recreated just for our HS cause we thought we had a fix and then the other is a brand new one simply for this testing purpose.

I don't know for certain, but I am led to believe it is WPA2.

If you remove the Configuration Profile and add the network normally, does it still have the issue? If manually adding the network doesn't reproduce the issue, then it can at least confirm that it's the Configuration Profile.

I'm stumped.

New Contributor II

Yeah I can connect to another SSID with leaving the "Bad" profile on the iPad and it stays connected.  No issue.  But the moment I try and connect to the SSID that is listed in the profile is when it breaks.