wifi not connecting

New Contributor II

i unchecked Allow connection to unmanaged Wi-Fi networks (supervised only) and i tried to check box again and won't connect any of my ipads to our wifi? im getting the message on ipad your ipad can only join wifi networks that are configured by your organizations admin.any idea to fix this


New Contributor III

Sounds like you applied a configuration which kicked your iPads off the network. You will have to connect them back to the network for them to get the updated configuration. You may have to lay your hands on each iPad.

We set the wifi configuration when we enroll ours, so I haven't tested this problem.

Hope this helps.


New Contributor

I am having a similar issue with some of our devices as well. We have a Wifi payload configured for all of our iPads and when I disable allowing connection to unmanaged networks some of the iPads will drop and then reconnect and some of them will just drop the network connection and never reconnect again. Haven't been able to identify the reason why. I can have two identical iPad types and iOS versions and one works fine and the other won't.

New Contributor II

yea ,our ipads we cant even try to manually touch the wifi settings and pick our wireless network, it keeps cycling with no wifi selection,i have to gather all 600 and restore each one of them all over again.

Contributor II

I don't have any hard evidence of this, but it seems that there are circumstances that will cause a wireless profile to install without actually doing anything. When I first experimented with restricting wifi networks I included logic that checked for the wireless profile, but had some devices lose all connection to the wireless, and I had to manually install the profile using configurator to fix it. All of our devices are setup by users, so they're already connected to the same SSID that the profile connects to, which I assume is part of the issue, but it's too inconsistent for that to be the only criteria.

In my experience it's best, if possible, to include the wireless configuration in the profile with the restrictions. This will guarantee that the device is able to connect to the wireless after the restrictions install.

New Contributor

Restart your wireless router. This is usually done by just pulling its power adapter out of the router for around 15 seconds and plugging it back in. ... — Try a reset of all settings on the iPad –

via Settings
General Reset
Reset All Settings

Change the passphrase on your wireless network.5506c39ab28c4ebaabeff0b1f4a5c587

New Contributor

Is there a fix for those who can't reboot their router? We're in a live production setting (a school) and there's no way I could get away with restarting that.

New Contributor

Here's what worked for us in iOS 11.

Managed WIFI networks must be secure networks, not open. Managed open networks disappear from the list of available networks as soon as we deselect and push out "Allow connection to unmanaged wifi networks".

This is different behavior than we see for iPads running iOS 10.3.3, where managed open networks still show up in the list of available networks after deselecting the option "Allow connection to unmanaged wifi networks".

New Contributor II

I was having this issue for over a week. The solution posted by bburdeaux works! Put the WIFI config in the restrictions section.