Wireless Configuration Profile Dropping/Breaking

New Contributor

At my institution we have laptops that students use to authenticate to our domain wirelessly. In order to do that they need to be connected to the wireless prior to logging in. In 10.6 SL we simply setup system level network profiles in the network GUI that connects to the wireless network prior to logging in and it worked out great. in 10.7 and 10.8 you don't have that option. System level wireless config profiles can't be done locally so I am deploying them via Casper. I've done that and it works great....for a while. Perhaps a day or so or several reboots and/or logins then it breaks. The wireless connection drops then never comes back until the machine is re-imaged. Has anyone ran into this problem? If so how did you resolve? Thanks in advance!


New Contributor

We are using Casper 8.71 btw


Personally we never had much luck using configuration profiles for wireless network settings.

take a look at https://jamfnation.jamfsoftware.com/viewProductFile.html?id=135&fid=468

and https://jamfnation.jamfsoftware.com/viewProductFile.html?id=135&fid=570

Valued Contributor

I've had the exact issue and had to resort to installing the profile locally.

Check out this thread for more information: https://jamfnation.jamfsoftware.com/discussion.html?id=7231

Valued Contributor

We use the local install method as well.
Use profiles command to install/delete configuration profiles.


New Contributor II

We've had a similar issue. Rebinding the machine to AD seemed to have fixed it though.

Might try installing the profile locally.

Release Candidate Programs Tester

Hmmm... We use system level profiles that get Certs from our internal CA.

& it works great when deployed through the JSS.

Not sure what we're doing differently.

Valued Contributor III

This is probably not the cause of your issue, but we run into a common-ish bug in 10.7 and 10.8 where the system loses its "KerberosServices" entries and starts writing blank entries into the AD attribute "servicePrincipalName" which is required for cert-based TLS authentication.

If you run "dscl . read Computers/localhost | KerberosServices" and get a blank response, that could be the problem. The issue pops up later in a system's life, usually within a couple days after imaging.

Edit: I opened a new case with Apple and they are pointing to Casper causing this problem by messing with the localhost file as a result of applying MCX controls.

Contributor III

Thanks for the resources. We've been having issues with our WiFi profiles when a computer needs to be reimaged. Maybe switching to manually installing them will resolve that issue.