Apple Classroom iPad OS 15 troubles

Aruky
New Contributor II

We’ve started seeing messages on students iPads in the classroom settings pane that „teacher and student certificates have expired“ and that classes cannot be joined. No idea where those certificates come from though. Any suggestions? 
TIA

16 REPLIES 16

CSNavigateurs
New Contributor III

We had the same issue ... we corrected this by adding text in Description of each class causing the certificate to be refreshed and sent to each. iPad

Aruky
New Contributor II

Tank you! A change in one class seems to have worked like you said! 

seankaiser
New Contributor III

We are seeing the same thing, which started yesterday for us. When we look at the certificates area under Settings > General > VPN & Managed Devices > Jamf School MDM Profile, we have 3 expired certs showing up (root.edu..., leader.edu..., and member.edu...) I created a Jamf School support ticket last night about the issue and added info this morning about these expired certs. We have ~5000 classes so I'm not about to go in and adjust the description for each class to get the certificates to be refreshed/regenerated.

CSNavigateurs
New Contributor III

Apple has confirmed that these certificates are under JAMF MDM control. The stand alone version of Apple Classroom sends a 1 year auth certificate is issued  when the classe is created by the teacher. JAMF has NOT responded to this issue ALL my classes now show all the iPADS offline !!!

seankaiser
New Contributor III

Ben in the Jamf School support group responded to my ticket that they "made a slight change on the backend of your Jamf School instance that should resolve that error message". After doing a device refresh against all of our devices, we checked with a few teachers and all of them are reporting that Apple Classroom is now working again. Hopefully you have opened a similar support ticket and can ask them to do the same thing for you that they did for us. (Since I'm not sure what they did, I'm guessing that if you reference our ticket number 107108, they can look to see what they did.)

Aruky
New Contributor II

Issue is still showing up intermittently at our school. Changing just one thing in any class, such as a description, makes it go away.  (I had an iPad showing "you need a valid education profile" and after hitting refresh /save in the classes section after altering one description of JAmF classes showed  up on said iPad almost instantaneously. But this can't be  a viable solution.

bfrench
Contributor II

We are not seeing the certificate issue - but students are randomly not connected.  I tried the tip of changing the class name.  A new EDU profile went out to the teachers iPad - but the students iPads did not receive an updated profile. Have an open ticket ...

Aruky
New Contributor II

We had an open ticket, JamF made changes, pushed a new certificate or some such and problem went away for a couple of days. Showed up again today. Removing and adding a student resolved the issue again but this can’t be a permanent solution. Our usual classroom fix for students not showing up was turning bluetooth and Wi-Fi off and on again, this doesn’t work anymore. Hard reset of students’ and or teachers device sometimes still helps but all in all the system is flaky. 

mramola
New Contributor II

We are experiencing this today as well.  I contacted Jamf and they are working on a resolution on the backend.  I did notice that to resolve it if the numbers are low (like one or two) I just quickly change the owner of the device to another student/teacher in that particular grade level (or however you have your devices grouped), and then back to the correct owner and it pushes out a new Education profile and that seems to resolve it.  I am thinking this is tied to the update to 15.  We had it blocked for students and teachers and just opened it up last week - now that our devices are running the update it seems to be causing the issue.  

carmichaelcolle
New Contributor

For anyone still having this issue I'll offer the workaround we implemented. Jamf support said to unassign and reassign the user, or enrol them in a new class so that their device will get a new EDU profile.
We created a smart group based on OS version 15 or higher, then created a new class manually in jamf and scoped it to the smart device group.
Now after a student (or teacher) updates their iPad, they are added to a new class and the device receives a new EDU profile. So far this appears to be working.

Hi,

you said "then created a new class manually in jamf and scoped it to the smart device group."

how can I scope a smart device group as a class? I can't find this option.

 

CSNavigateurs
New Contributor III

We have over 300 classes .... can't start a procedure like that as they are in 55 schools ... and the issue comes back after a week or so ...

BGSICTSupport
New Contributor III

Hi,

Has the cause of this issue now been discovered? We are seeing it on more devices as the days go by.

Is it a Jamf or Apple issue?

Sway
New Contributor

My Support said, that it should be fixed with iPadOS 15.1.

It's better but not 100% solved.

BGSICTSupport
New Contributor III

Does simply updating to 15.1 resolve the issue or do the classes need re-pushing to them after they've updated?

Thanks,

Sway
New Contributor

Actually I don't know. I re-pushed them all before.