Default Path of OSX Users /Users (Symlink) Appstore Failed...

New Contributor

Hi there,

At the moment I use a symlink with points /Users to an other Drive(RAID).
everything is working fine, exept the login to Appstore... (AMD Auth.. Error)

I tried everything also with the Shared folder and a ditto -V to copy the existing Shared Folder to the External RAID, but it doesn't help. Only if /Users/Shared is no a symlink.. the login works on Appstore.

I need all Users on my RAID because we use OD with local homes.

Is there a way to change Default /Users to example: /Volumes/Data on every new created account?

Glad for help.



New Contributor

I have this exact same question. I want to create all new user accounts on a 2nd Partition called /Volumes/UserData. I tried doing a symbolic link from /Users to /Volume/UserData/Users but then you can't log into the AppStore. Seems it's hard coded to access /Users/Shared but won't follow Symbolic Links (really frustrating).

The alternative is to have all new user accounts created directly at /Volumes/UserData/Users instead of /Users. Is there a way to do this??

Valued Contributor

You could mount /Users to the other disk/partition with an entry in /etc/fstab.
It's been a few years since I've done this, but there should still be posts about this floating around here somewhere...

New Contributor

Thanks. I was able to get the Mount working and it seems fine but I still can't access the App Store. Same error.

I think the only solution that will work is to leave the /Users folder as is and have new accounts created at /Volumes/UserData/Users. But we don't have the time and resources to do this manually for every person that logs into a computer, especially when we don't manage who logs into what device once it is loaded and placed it into an office