Enable root GUI via first run script


Hey all,

Not strictly a casper question per se however thought I'd give it a run here. I'd like to enable root as part of my first boot script in the imaging workflow. May of our techs aren't comfortable using the CLI and with my old base OS images I would enable root using the GUI and set up a basic dock with tools etc that they could use. I realise that it was handing over a lot of responsibility that they could login as root however it worked for us in the past. With a never booted image I can't seem to be able to allow the root account to be activated so they can log in should they need to.

I have used dsenableroot [-u username] [-p password] [-r rootPassword] entering the appropriate admin user, password and root password however they can't login nor authenticate as root. When I look at Directory utility I can see that root has been enabled and the option to change the password is possible which tells me that the above command in the script worked but isn't quite there. Once logged in as an admin I can run sudo su, passwd and enter the root password twice which then allows root to be fully enabled but I can't seem to work out how to script that and bypass the prompts

Does anyone know how to fully enable root to allow authentication and to login to the system as root?

Any help always appreciated.


Valued Contributor III

So I guess I will be the guy that asks why would you want to lower security by doing that. For techs with issues using command line, might I suggest you making an Automator applet with a "run shell script" action pre set up with what they want to do via command line. Very similar to a downloaded Microsoft fixit package only you build it as the sysadmin.

Contributor III

So I have been wondering about this but for a different reason. JAMF recommends for Casper Imaging with netboot to run as root. I have been trying to create a never booted, netboot set which does the automated login as root and then uses a launch agent to run casper imaging. I can make it all work with a "admin user" but I can't figure out how to enable root on never booted NetBoot.dmg.

New Contributor II

I'm tackling this same issue now. I am moving away from a pre-configured base image and using AutoDMG to create a never booted DMG that I lay down with Casper Imaging. I then install my software packages and captured "User Environment" settings. FirstRun script then binds to AD, creats a local Help Desk admin and sets Open Firmware (I inject the setgrepprotocol at imaging). After reboot I need to enable the root user and then hide the Help Desk account (this I can do). If I make progress I'll let you know, but I want to script enabling the root user.