Font Issue - Blocks / Question Marks

New Contributor III

Hello - Running JSS 10.4.1 , not sure what the point of failure is but I only notice this issue on machines that ARE encrypted or getting encrypted - Randomly and interrmitenttly (at least for the first few logins) ALL of the system fonts become blocks with question marks. I tried changing my MS office packages to the latest (I think it's related for some reason) but can't find a reason it happens. I THINK running atsutil might fix it but not sure.


New Contributor II

Do you have a policy with a maintenance payload running with " Flush System Caches Flush caches from /Library/Caches/ and /System/Library/Caches/, except for any caches

Flush User Caches Flush caches from ~/Library/Caches/, ~/.jpi_cache/, and ~/Library/Preferences/Microsoft/Office version #/Office Font Cache " checked? We had this issue for along time and turning them off solved the problem.


New Contributor II

This worked for us too. Thanks ;-)

New Contributor II

You might be absolutely right about encrypted hard drive, It's happening on my main computer at work, and five oter users. After troubleshooting for several days with Apple support I gave up and continued my own troubleshooting. I have searched the web, and even though there's a lot of the same questions, the solutions posted are far from solving my problem. I have the feeling that everybody is lost and desperate trying to find a good solution to this problem but we are all hopeless.
I already reversed about four Imacs thinking that the problem could be related to hard drives formatted as APFS.
I will reformat my computer using Mac OS Extended instead of APFS. I will stay away from that new encrypted format for a couple of years
Until Apple promise that all problems have been solved.