In-House eBooks

New Contributor


i create an In-House eBook which is a pdf file (using hosting location is web server) and i distributed to our organization ipads devices, but the eBook did not deploy to any device its give me an error (The MDM request is invalid) .

i read some articals that i shoud not use space in ebook display name and i have to use a version but nothing works

i hope that someone can help me on this !!


Valued Contributor

It's been a while but ones that I deployed did have a space in the display name.

They never had a space in the ebook url name as below (that could of been just me and how I named files.)

Also it does not look I used a version number on some that I know worked but maybe requirements have changed. What worked best for me was scoping to a device and set to auto-install.

My only thought besides a hosting / permission type rabbit hole would be, have you also tried deploying in the epub format. Just to eliminate any issues with how the pdf is created, bloody pdf's.