Jamf App Installers - User notifications

dcorona
New Contributor II

Testing out the Jamf App Installer User Notification settings configuration profiles with the recommended setting:

Best Practice: Jamf recommends choosing Persistent from the Banner alert type pop-up menu. You may c...

While we would like update notifications only to be Persistent, we found that ALL notifications are Persistent.
eg. Slack messages stayed on the screen, which is not desired.

Can Jamf separate user notifications and just target update notifications?

18 REPLIES 18

JefferyAnderson
Contributor

I see no replies to this. We are having the same trouble. This is not a good user experience.

dshore-aspen
New Contributor

We're having a similar problem in our instance. By creating these config policies we've overwritten the notifications for the apps themselves.

jamf-42
Valued Contributor

had this recently.. with Slack.. JAMF sets this to an Alert.. and I made my pilot users very happy ๐Ÿคฃ

I questioned this with support and the answer is to remove the JAMF config profiles deployed by Jamf app installer and roll you own. For Slack we already had a config profile... so not a huge issue, but your correct, some apps use notifications as part of the app.. so we should have a more granular control.. like being able to edit the config profile.. a bit more work.. as for some, you need to take the App installer config profile.. rework it and deploy via custom payload..

markopolo
Contributor

I concur. This is maddening, and can't believe this feature made it out of internal beta testing. I have users complaining about everything from Slack to Outlook to Adobe Reader. Terrible approach to notifying users about updates. Like why couldn't they have leveraged Self Service notifications for this?

rhs615
New Contributor III

Has anyone figured out a way to remove the App Installers - Slack config profile that is deployed via the Mac App record for Slack? Unchecking the box on "Install supporting configuration profiles"  has not removed that from users' workstations. 

jamf-42
Valued Contributor

add this schema.. set how desired.. push

{
  "title": "Slack (com.tinyspeck.slackmacgap)",
  "description": "Slack settings",
  "properties": {
    "SlackNoAutoUpdates": {
      "type": "boolean",
      "title": "Disable Automatic Updates",
      "default": false,
      "description": "When true, disables Slack's built-in automatic update mechanism. Useful if you update Slack using a tool like Munki.",
      "links": [
        {
          "rel": "More information",
          "href": "https://slack.com/help/articles/360035635174-Deploy-Slack-for-macOS"
        }
      ],
      "property_order": 5
    },
    "SlackDefaultSignInWorkspace": {
      "type": "string",
      "title": "Default Workspace",
      "description": "Sets the default workspace for Slack sign-ins.",
      "links": [
        {
          "rel": "More information",
          "href": "https://slack.com/help/articles/360041725993-Share-a-default-sign-in-file-with-members"
        }
      ],
      "property_order": 10
    }
  }
}

 

rhs615
New Contributor III

Thanks! This worked to deploy, but didn't remove the "App Installers - Slack" and therefore has still locked the Notification settings for Slack. Any thoughts? 

jamf-42
Valued Contributor

stop the app deploy. check management history on devices. you should see the APP Slack config "pulled". depending on scope size etc.. wait till they are all cleared (you can make a smart group if req) . push config profile to all again. just in case.. that config profile now sets Slack prefs. 

rhs615
New Contributor III

Will this uninstall the application too? 

 

jamf-42
Valued Contributor

no. app stays. just updates are off. 

rhs615
New Contributor III

Thank you so much! You're my hero. 

jamf-42
Valued Contributor

beware the config profiles deployed by 'Jamf Mac Apps'  some are ok.. others not so..  test.. scope small.. check.. review.. 

rhs615
New Contributor III

Certainly learned that the hard way now. smh ๐Ÿคฆโ€:male_sign:

JustinC
Contributor II
Contributor II

We have made significant changes to the end user notifications behaviour in the last month as well as providing some additional controls in Jamf Pro 10.47. We cover some of these changes in this article https://community.jamf.com/t5/jamf-pro/update-on-end-user-notifications-app-installers/td-p/292215 and this blog post https://www.jamf.com/blog/app-installers-deploy-to-Self-Service/

JefferyAnderson
Contributor

Hey @JustinC , I've just set up a new App Installer to handle Zoom updates. The notification is working, but it's presenting as a Banner instead of an Alert, so it doesn't stay on screen. I feel my users will miss the notification if it just appears briefly and then goes away. How can I fix this? Here is what I'm seeing in the GUI for Self Service notifications:

SS notification.png

@JefferyAnderson , your screenshot shows that your setting is correct. Notifications for Self Service are set to Alerts and they don't go away. After recent update, which was mentioned in this article, all update notifications are sent with Self Service BundleID. So they use Self Service settings for notifications and are separated from the notification settings for particular application. You can have notifications for Zoom set to Banners or even None but your users will still see persistent notifications about app update (thanks to Alert notifications for Self Service).

JefferyAnderson
Contributor

Doing some more testing. I've found that if I select "Allow notifications when mirroring or sharing the display", then the Alert will remain persistent in the top-right corner. How can I make this work without having that setting enabled?

 

allow notifications.png

JefferyAnderson
Contributor

I figured out my issue. Bomgar had a setting that was sending an image of the screen to the Representative Console. Once I changed this setting on my Bomgar server, things started acting normal.