NetInstall / NetRestore Process for installing Vanilla OSs?

apizz
Valued Contributor

For a while now I've been using the createinstallmedia tool built into Install OSX installer apps to build bootable OS installers from USB. However, I want to create either a NetInstall or NetRestore image such that I can boot machines to our Netboot server and only install the desired Mac OS so my colleagues can use this as well. Don't want this to have anything to do with the JSS (jamf pro).

Thus far, my attempts to do this haven't worked. Here's what I've tried:

Build NetInstall Image w/ System Image Utility
1. Download OSX Installer app
2. Make OSX Installer app the source in System Image Utility and leave default settings. (this successfully builds).
3. Once built, I upload to /Library/Netboot on our Netboot server. Change the "Make available over" setting to NFS from HTTP (but I've tried both ways with same results below).
4. Reboot and hold down option on test machine I want to install on and see the Netboot. As soon as I select the Netboot, however, instead of booting to the NetInstall it instead boots right to the primary Startup Disk - the internal drive.

I've tried doing the above process but instead with a NetRestore image to the same effect.

Am I missing something? Thanks in advance.

1 ACCEPTED SOLUTION

apizz
Valued Contributor

Permissions permissions permissions ...

Had some messed up file permissions in the NBI which was preventing netbooting for the OS X install ... Must have happened when I copied from my build machine up to the server.

doh

View solution in original post

6 REPLIES 6

apizz
Valued Contributor

Permissions permissions permissions ...

Had some messed up file permissions in the NBI which was preventing netbooting for the OS X install ... Must have happened when I copied from my build machine up to the server.

doh

View solution in original post

bjones
New Contributor III

@aporlebeke
Question i am having the same issue and i went and checked the permissions and they all look to be fine. I would like to add that i am also using the Netboot option where i have fully functional Netboot images placed in the same NetBootSp0 location which can be seen when holding down the option on reboot and i can image a system enrolled in the JSS with the set configurations.

I just cant get this plain Vanilla Sierra OSX image i created for netinstall. When selected during the OSX option load it just bring me right back to the image that was on the system previously.

bjones
New Contributor III

@aporlebeke

lol never mind patience grasshopper patience on my side 🙂

apizz
Valued Contributor

@bjones was it in fact permissions?

eosuptrade
New Contributor

@aporlebeke Which permissions? Could you post a ls -la ? Or explain what was missing where??

apizz
Valued Contributor

@eosuptrade IIRC, because I had built the Netboot on a test laptop and then either copied directly to our Netboot server or uploaded to our central fileserver before copying to our Netboot server, something with the file ownership and permissions was wrong. Owner was my user and IIRC was only rwx (700 rwx------) for me therefore not readible by everyone.

I believe most Netboot file permissions are 644 (rw-r--r--)