network setup is trying to modify the system network configuration - Password ?

Contributor II

I've seen this a little bit in the last while, but I'm really seeing it now that I have upgraded from 8.73 to 9.21. Today if I go to one of my client machines I can see that the new version of Self Service is on the machine
but when I go to launch it I get a dialog box that says. "networksetup is trying to modify the system network configuration. Type an administrator's name and password to allow this." If I put in that admin password Self Service then launches and works fine. I think I've also seen this when a configuration profile is being pushed out Any idea as to what is up with this ? The Self Service app has always launched perfectly on our clients in the past.


Contributor III

Mavericks? I had to modify Tim Sutton's to manipulate /Library/Application Support/ when I wanted to use SelfService for some tasks.

Contributor II

No these are mostly 10.8 clients and a few 10.7. We haven't really deployed much in the way of Mavericks yet in the field. We have some IT users on it and a few servers, but that's about it. This is really mostly affecting 10.8.x clients.

Not applicable

Just ran into this today, on the first 10.8.5 machine I'd freshly imaged from Casper 9.3. Not sure what's up. Happens every time I open Self Service. Guess I'll reach out to support...

New Contributor II

We had the same problem. It turns out it had to do with a script we had to implement last summer when our newly imaged computers would not get named at the end of the imaging process. After a long elimination process (by one of my colleagues) we found that the script that had helped us in the past was the root of the problem. (Think back to OS 9 and older times when you tried to eliminate which System Extension was causing your computer not to start up!)

JAMF had helped us come up with the script so we asked them and they said there is another option to fix the 'non-naming' problem.

Remove the following file from your OS Package:


That helped us solve both the 'non-naming' problem and the request for the admin password when opening Self Service. (Now I just have to remember to remove it from the current OS X 10.9 package I'm currently working on. Although neither problem seems to be rearing it ugly head even with the file still in place.)


Very belated post to an old thread, but I ran into this issue while trying to update the last legacy 10.8 Macs (~100). I wanted to avoid nuking /Library/Preferences/SystemConfiguration/preferences.plist . Not only was jamf version causing this prompt of "trying to modify system network config...", other operations were not "sticking"; e.g. sudo scutil --set HostName <> did not commit; I kept seeing "Hostname not set".

That lead me notice POSIX perms were off: they were 600, but should be 644 (owner/group were already set as root:admin).
sudo chmod 644 /Library/Preferences/SystemConfiguration/preferences.plist
Confirm perms look like this (obviously size/date/time vary)...
-rw-r--r-- 1 root admin 13K Apr 6 13:16 preferences.plist

After this, HostName correctly showed my setting, and jamf version (or any Jamf verb) no longer caused the annoying prompt about "trying to modify system network settings..." Yay!

Not that many 10.8 Macs should be out there, but this issue prevented us from upgrading to newer macOS versions.