ssh error when using Recon for enrolment

Not applicable

Hi all,

Hoping someone can give me a hand with an error I am seeing on ssh when trying to enrol machines into Casper using remote enrolment on Recon. When trying to connect to the remote Mac I am getting an error in ssh. The error message says "SSH failed to create session with host '...' (Failure establishing socket connection). I've checked on the remote machine Sharing preference pane and the remote login and remote management boxes are enabled and they are both enabled for the local admin account. Any ideas why this maybe happening? Everything is set the way I have it set on other Macs and enrolment has worked on all the Macs I've tried it on other than the 2 with this error. One other thing which confuses me. I can't ssh via the command line from a remote Mac as it just hangs without any error message, but I can connect on the locally with ssh admin@localhost.

Thanks for any ideas you can throw my way.


New Contributor

This helped me when I had that issue: