Jamf Connect not recognizing network password

New Contributor II

I am starting to see users have issues where all of a sudden they cannot sign into their devices.  Jamf Connect states their network password is incorrect.  No password changes or anything.  They can login elsewhere fine (Windows machines, work email on personal phones, etc) but just not their Macs when they are prompted to sign in.  I have seen similar questions asked on here but none seemed to have an answer.  Hoping maybe someone may know whats going on.


Valued Contributor

I think that's a bug in Jamf Connect. I noticed that when it says "network" password, it actually means the local password.

New Contributor II

What's weird though is it still doesn't take what the local password would be.  This user just enrolled via user-initiated enrollment a week ago and their Mac password was the same as their network one.  They ran a script to demobilize the account followed by activating jamf.  Upon reboot everything worked fine for a week.  Today they were unable to login.  We had a workaround of a local admin account that we could use to login and reset the users password so we did that to the same password but we are slowly seeing it happen on more devices so id like to resolve this before it becomes widespread.

Valued Contributor II

Have you confirmed that the MS changes to MSAL in Dec are not the issue??


Integrating with Microsoft Azure AD - Jamf Connect Documentation 2.19.0 | Jamf

I have not!  That looks very interesting.  Im going to get with my Azure guy and go over this.  I'll let you know.  Thanks!