10.12 Server authentication prompt with keychain

New Contributor III

This is more of a general OS X question.

I recently had to upgrade a bot mini from 10.8 and to 10.12.

In 10.8 when you connect to a server and you have the password saved in the keychain, the server simply mounts with no authentication prompt. Im finding in 10.12 that even though you have the password saved in the keychain, you still get the authentication prompt. The password IS filled in for you, but you are required to click ok.

This is problematic for me. I have a launch agent setup to call an applescript that does various things. The first thing it does is check if a particular server is mounted, and if not it mounts it. It is now getting stuck at the authentication prompt.

Is what I am experiencing expected behavior? Is there a way to get the mounting of a network volume to work as it did before without the authentication prompt?


New Contributor

Is this a SMB share? We've been having all sorts of problems with SMB ever since 10.11.?

Otherwise, I would try deleting the keychain entry and recreating it. And no, if the password's been stored, it shouldn't prompt you; it should just mount it.

New Contributor III

It seems to be a problem with 10.12 Sierra. I can replicate the problem across multiple machines with both SMB and AFP shares. I cannot replicate it on 10.10. or 10.11. and of course 10.8 like I mentioned. I don't have 10.9 to try.

I even created a fresh 10.12 install to test. Immediately after install I connected to an afp share and saved the password in the keychain. I unmounted and tried to reconnect and I got the authentication prompt with the password filled in. I clicked ok and it mounted.

Can anyone confirm they are experiencing this as well?

Contributor III

As others have pointed out in other threads, the following should resolve this while thwarting the new security measure. Unfortunately I do not see any documentation on a "known servers" acl that could be modified to only allow those which you trust.