adobe acrobat reader dc updater script error

tcandela
Valued Contributor

does anyone use the Acrobat Reader DC Updater script obtained from the JAMF 'Resources' --> 'Scripts' section?

seems to fail 90% of the time, no matter what version prior to the newest version is installed. Here is a sample details taken from the policy after it failed.

@amartin has this adobe acrobat reader dc updater script been fixed yet? I just grabbed it earlier today and it's nothing but spitting out error when trying to update to current version (see below taken from policy details of one computer that is currently running 20034).

90% of the time this script is causing an error, while 10% of the time it works

i added an additional echo so it also shows it in the policy details
in the 'else' section of the # double check to see if the new version got updated

Script result: Latest Version is: 2020.006.20042
Latest Version Norm is: 20.006.20042
Current installed version is: 20.006.20034
ARCurrVersNormalized: 2000620042
Latest version of the URL is: http://ardownload.adobe.com/pub/adobe/reader/mac/AcrobatDC/2000620042/AcroRdrDC_2000620042_MUI.dmg
Wed Mar 25 16:31:06 EDT 2020: ERROR: Adobe Reader update unsuccessful, version remains at 20.006.20034.

7 REPLIES 7

sk8559
New Contributor II

Even i am facing issue, May be @amartin253 can help here. Below is my logs adding @chris.hansen @donmontalvo @Cornoir Script result: dmgfile=acrobat.dmg
logfile=/Library/Logs/AdobeAcrobatDCUpdateScript.log
'[' '/usr/bin/uname -p=i386' -o '/usr/bin/uname -p=x86_64' ']'
sw_vers -productVersion
sed 's/[.]/_/g'
OSvers_URL=10_15_6
userAgent='Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/535.6.2 (KHTML, like Gecko) Version/5.2 Safari/535.6.2'
latestver=2020.012.20041
echo 'Latest Version is: 2020.012.20041'
Latest Version is: 2020.012.20041
echo 2020.012.20041
sed -e s/20//
latestvernorm=20.012.20041
'[' -e '/Applications/Adobe Acrobat DC/Adobe Acrobat.app' ']'
/usr/bin/defaults read '/Applications/Adobe Acrobat DC/Adobe Acrobat.app/Contents/Info' CFBundleShortVersionString
currentinstalledver=17.009.20044
echo 'Current installed version is: 17.009.20044'
Current installed version is: 17.009.20044
'[' 20.012.20041 = 17.009.20044 ']'
+ echo 2020.012.20041
sed -e 's/[.]//g' -e s/20//
ARCurrVersNormalized=2001220041
echo 'ARCurrVersNormalized: 2001220041'
ARCurrVersNormalized: 2001220041
url=
url1=http://ardownload.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/2001220041/AcrobatDCUpd2001220041.dmg
url2=
+ echo http://ardownload.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/2001220041/AcrobatDCUpd2001220041.dmg
url=http://ardownload.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/2001220041/AcrobatDCUpd2001220041.dmg
echo 'Latest version of the URL is: http://ardownload.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/2001220041/AcrobatDCUpd2001220041.dmg'
Latest version of the URL is: http://ardownload.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/2001220041/AcrobatDCUpd2001220041.dmg
'[' 17.009.20044 '!=' 20.012.20041 ']'
+ date
/bin/echo 'Thu Aug 27 07:13:39 EDT 2020: Current Acrobat DC version: 17.009.20044'
+ date
/bin/echo 'Thu Aug 27 07:13:39 EDT 2020: Available Acrobat DC version: 2020.012.20041 => 20.012.20041'
+ date
/bin/echo 'Thu Aug 27 07:13:39 EDT 2020: Downloading newer version.'
/usr/bin/curl -s -o /tmp/acrobat.dmg http://ardownload.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/2001220041/AcrobatDCUpd2001220041.dmg
date
/bin/echo 'Thu Aug 27 07:23:11 EDT 2020: Mounting installer disk image.'
/usr/bin/hdiutil attach /tmp/acrobat.dmg -nobrowse -quiet
date
/bin/echo 'Thu Aug 27 07:23:12 EDT 2020: Installing...'
/usr/sbin/installer -pkg /Volumes/AcrobatDCUpd2001220041/AcrobatDCUpd2001220041.pkg -target /
/bin/sleep 10
+ date
/bin/echo 'Thu Aug 27 07:23:23 EDT 2020: Unmounting installer disk image.'
/usr/bin/hdiutil detach /Volumes/AcrobatDCUpd2001220041 -quiet
/bin/sleep 10
+ date
/bin/echo 'Thu Aug 27 07:23:34 EDT 2020: Deleting disk image.'
/bin/rm /tmp/acrobat.dmg
/usr/bin/defaults read '/Applications/Adobe Acrobat DC/Adobe Acrobat.app/Contents/Info' CFBundleShortVersionString
newlyinstalledver=17.009.20044
'[' 20.012.20041 = 17.009.20044 ']'
date
/bin/echo 'Thu Aug 27 07:23:34 EDT 2020: ERROR: Adobe Acrobat update unsuccessful, version remains at 17.009.20044.'
/bin/echo --
exit 1

tcandela
Valued Contributor

I found that sometimes it was because the installed macOS was not compatible with the current version of adobe reader.
Computers running version 17 or 18 of reader weren't compatible with current versions 20.

mvu
Valued Contributor

The update packages Adobe publishes themselves fail on me a lot. Glad Jamf added the Retry option. It appears version 20.012.20043 is the latest for Reader & Acrobat, but Adobe only offers 20.012.20041 ATM. So that can cause some hiccups for me.

https://helpx.adobe.com/acrobat/kb/install-updates-reader-acrobat.html

sk8559
New Contributor II

@mvu i tried with version 20.012.20041 in my script but it still fail, not idea what need to be changed/modified.

xtian
New Contributor II

get it here : Jamf Script Repo

cbrewer
Valued Contributor II

cwaldrip
Valued Contributor

Looks like Adobe broke something again?

The requested URL /pub/adobe/reader/mac/AcrobatDC/2100120138/AcroRdrDC_2100120138_MUI.dmg was not found on this server.