Adobe Captivate 2017


I am trying to roll out Captivate to some staff using a Install PKG built with CCP.

The target computers are all Mac OS X 10.12.6

The install fails every time with the dreaded "The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)" message in the Jamf Pro logs.

Other Adobe installations run fine (Photoshop, Premiere etc, etc) - and I have tried using the Creative Cloud Cleaner Tool to ensure the installation is fresh. I am still getting no joy.

All the installers for our adobe software where rebuilt in August (so the expired certificate issue should not be the problem.) I have rebuilt the Captivate pkg today, and still have the same issue.

Any advice would be appreciated

thanks in advance.

Update: To save people reading through multiple posts, i have no also tried

  • Wrapping the installer in a DMG
  • Caching the PKG and installing from there
  • putting the PKG on the local drive and manually installing
  • Self Service.

It appears to be a broke PKG - but I cannot find any alternate methods of packaging Captivate 2017.


Valued Contributor III

Are you running the pkg directly out of JAMF?
When I get problematic ones I usually just wrap them up in the DMG in composer send them out to the local drive and call them with a script.
The other consideration is if it's trying to modify the UI, this can cause pkg's to fail if there is no logged in user, try running it as a self service policy, if that works then this is probably the issue.


I tried that and it failed - same as caching the installer - or even trying to run the PKG locally on the system (which normally works with the Adobe packages)

I am thinking there may be an issue with the PKG itself (similar to the cert issue they had back in Feb.).. but I cant find anyone else experiencing the same issue.

I will try the Self Service idea though.

Update: It failed in Self Service as well.

Contributor II

Sounds like its a problem with the pkg. Try and install the pkg manually, if you get the error when you run it manually then its a problem with the pkg. You'll have recreate it the package using the create cloud packager, then import into Casper Admin again.



Yea, i think it is the PKG - or at least the way CCP is building this particular app's installer.

I've recreated it several times (using clean systems, so there is no cached hold-over from previous build attempts) and it still fails - even running it manually.

Yay Adobe.....

New Contributor II

@mjames Did you find a solution? We're currently experiencing exactly the same thing, where the CCP-created package fails to successfully install (even when the CCP-created package is just double-clicked), with the same error message you saw. We've tried creating the CCP package on both 10.12.6 and 10.11.6... same result.


I didn't.

All the other CCP apps work fine - it is only Captivate that fails.

In the end, so few systems needed it, we just completed manual installs.

New Contributor II

@mjames We just found that disabling remote update manager when creating the package in CCP did the trick. We always have that enabled but that seems to be the culprit in the case of these Captivate issues.


Cool. I will give that a go when I get a minute. Thanks!