Adobe CC Install error

New Contributor

Had a user request Adobe Audition , so i did the usual of creating a package from the admin console on then uploading the installer from the Build folder and adding to Self Service.

Package works fine if i just run it manually, but it fails if i try and run it from Self Service with the following error .

The installer reported: installer: Error - An error occurred while running the InstallationCheck tool for “Adobe CC Audition 13.0.7_Install”. Try running the tool again

This is on Catalina 10.15.5 , I've had a search and seen threads saying that CC 2019 does not like Catalina but CC 2020 does. I presume a package i make today would be CC 2020?

Is there something special i need to do now to make CC packages install from Self Service on Catalina? I've noticed the Photoshop package we made last year also fails with the same error message on Catalina.


New Contributor

Hi, did you ever find a resolution for this? I'm getting the same issue trying to deploy the CC desktop app. /var/log/install.log has a tiny bit more info:

installer[1526]: Could not run InstallationCheck in the ACC Desktop_Install package. launch path not accessible

New Contributor III

Not sure if this workaround will work for everyone, but I had this same problem, and I was getting the same error message with an Adobe package that was created from the Adobe admin console. My package included Adobe CC Desktop App and Acrobat DC and was built on Dec 20, 2020. So it's the latest version of the Adobe apps to the date of writing this, and I was getting the same error message when installing it on Catalina from Self Service or using the policy event name.

My workaround was to go into the "Build" folder of the downloaded Adobe package, find the non-flat installer pkg, compress and zip it locally first, and then upload the zipped install pkg to Jamf Pro. Then add that package to the Jamf policy, and it successfully installed from Self Service and the policy event name. The notable difference here is to zip the non-flat pkg locally on your Mac before uploading to Jamf instead of having Jamf zip it when you upload it.

Here are the more detailed steps of what I did:
1. Build the Adobe package in the web-based Adobe admin console. My package was Adobe CC Desktop App and Acrobat DC, named user licensing.
2. Go through Adobe's tedious process to download that package to your local Mac, which will be a zip of all the package contents. Unzip it to your local Mac.
3. Go into the unzipped directory of your Adobe package, find the "Build" directory, and there should be the _Install and _Uninstall non-flat PKGs for your Adobe package
4. Right click the _Install package and select Compress, which should compress it into a new zip file in that same Build directory
5. Upload that zip file to Jamf. I'm using Jamf Pro 10.26.0 and upload through the Jamf web console instead of Jamf Admin. So I create a new package in the Jamf console and select my Adobe package's zip file from my local Mac
6. After it's done uploading, add it to our Jamf policy and try installing that one from SS

Oddly, I didn't have to do this for previous Adobe packages that I built earlier this year with the same CC apps, but I had to do it for this latest version. This worked for me and hopefully it works for some of you as well!

New Contributor III

Thank you, this had been seriously pissing me off

New Contributor III

I haven't had any troubles with that specific error message, but be advised that the installers for the 2021 versions of the Adobe Creative Cloud apps will likely fail if any version of that Creative Cloud application is open.

We rely pretty heavily on the CC applications, and sometimes use plugins that haven't been updated for the bleeding edge versions, so we allow for side-by-side installations of the latest two years of InDesign, Photoshop, and Illustrator. The newer installers do a fairly good job of attempting to migrate preferences from the older version to the newer, which is likely related.

I don't think that is likely to be the cause of what you're seeing, as it's a different error message, but I also haven't tried it on Catalina to see if the message changes.

New Contributor

Thanks Alexk, that worked for me. I found this after opening a ticket with Support so i guess i"ll to figure out why and the difference though since I have packages from Adobe from just a month or so ago that didn't require the workaround you provided. I'll report back if I find out any specifics.

New Contributor

Thanks Alexk,

That worked for me. I followed your steps and voila!!! it's installed.

New Contributor

Nice, Alexk's post helped me with this issue as well!