Anyone know where DEP server info is cached on OS X?

Valued Contributor II

OS X here, not iOS.

Client has 2 MDMs: Casper Suite for OS X and Meraki for iOS. Client also recently enrolled in DEP.

I imaged a new Mac, but started getting prompts to enroll in their MDM (Meraki). No, don't want to do that. Had the client log into, add in a second MDM server and migrate that serial number to the secondary server. However, each time a user logs in, they are prompted to enroll in Meraki MDM.

I ran into a similar issue last year with iOS MDM (except it was a misconfigured URL). Once I fixed it, iOS devices still kept prompting to enroll with the misconfigured URL until they are wiped.

I don't want to wipe-and-reload this Mac... there has to be a way to flush/purged the cached MDM server information.

I've opened a ticket with JAMF Support but thought I would run this past the community. If JAMF provides me with a solution, I'll share it in this thread.



Valued Contributor II

Support asked me to remove /private/var/db/.AppleSetupDone and /private/var/db/ConfigurationProfiles and restart, which I did.

This invokes the Setup Assistant on the next boot. Created temporary 2nd local admin account and was still prompted. Logged out, logged in as the local admin (to delete the account), and also got the prompt. Drat.

(Deleted the 2nd local admin account ran a sudo jamf mdm to get the MDM and scoped config profiles back on the device).

Logged out, logged back in as the user, and was not prompted. So, not sure if it just took some time to clear up, not sure. Will monitor to see if the prompt keeps reoccurring...


Hope to hear the final resolution.