App Distribution - Management Status Stuck on Installing

New Contributor II

Hey everyone,

Bit of a tricky one here. When I built a large number of devices, there is a slight chance a few of them will be stuck like this. The apps will be stuck on "installing" from the app catalog and will never show on the device.

Here are some things i've tried, - Refresh the app licenses
- Add the affected apps to the exclusion, then back to scope again
- Clear the pending apps and perform an inventory update (This will usually clear the blank "installing" list momentarily till it hangs on the same apps)
- Renew the MDM profile

Unfortunately it seems like I am forced to either manually install the apps (which then makes it managed), or wipe the device and start over, both of which take a bit of planning to take care of as these are daily drivers at a school.

Working with JAMF, there are no direct solutions to this outside of the two options I mentioned above. Has anyone else experienced this?

Thank you.



Valued Contributor II

I do not have a solution but I will say we have seen this a few times too and have recalled them for a Wipe after trying the same things you did. It seems to somewhat coincide with the problems Apple was having last week with app licenses. Since our students are at home, we do not really know the extent yet as they will likely trickle in.
I was able to get one going by flushing commands and allowing the apps to rescope, have had to wipe two so far
I also ran the mysql command: select * from vpp_licenses where apple_license_id=-1; and there was no issue there.


We have seen these more than a few times. I have not figured out why it happens but typically we can get things installing if we cancel the app installations and do an inventory update and wait a bit we can usually get the apps to install. You can clear out the app installs by going into the Inventory tab and then apps on the left. You can see them in the pending tab with a cancel button. It might take a few tries but for the most part this has worked for me.

New Contributor II

Also experiencing this issue. Hopefully there's a resolution soon :(

Edit: for clarity, I'm actually seeing this issue where a single app store app is being deployed. User is stuck on installing, even if I clear it.

New Contributor II

@shhtephe ,

Yeah, it's frustrating when it happens, especially since it's difficult to get my hands on the device at times. I am currently chatting with JAMF support again and will update you all when I can.

New Contributor

Did you ever get a solution to this? I'm having this problem that even after multiple wipe and resets, different apps fail each time and the ones that failed previously will install.

New Contributor II


Nothing at all. I've escalated this as high as I could only to come back empty handed. The two options I mentioned in my original post are the only options I have found to resolve the problem, Jamf has no other alternative right now.

I have asked to be notified for any changes and will update the thread if i get something.

New Contributor

Had the same problem, only 4/6 apps scoped installed, last 2 stuck on installing. I reset the iPad, then added it back to the correct Department in jamf, then all 6 apps installed.