Apps installed in Jamf but not on the iPad

New Contributor


When i started installing the iPads the distribution of the apps worked fine.
The apps were working on all iPads but then disappeared on some.

I have now a problem with distributing apps. In Jamf School they are shown as installed, with size and version number, but on some iPads (~25%) they arent shown on the app drawer. In the eventlog everything looks fine. I tried to "Retry -> Retry to install on missing" and "Retry -> Retry to install apps that are stuck to installing".

Should i do a wipe on these iPads?

Thanks in advance



Valued Contributor II

You could try several things but a wipe & restore may be the best option. On one of the affected iPads open the Settings app goto General > About > > iPad Storage and see if one of the missing apps is listed there. Another thing to try is if the App Store is available search for a missing app and see what the status of it is i.e. Get or loading indicator.

Contributor III

Do you have a profile that is restricting certain apps or only allowing certain apps?