Black screen after security update 2015-003 Yosemite 10.10.2

g1za
New Contributor III

My personal Mac is doing my head in!!!

I installed the security update 2015-003 and it restarted into a black screen. The Mac itself is working fine, but display wise i can't see anything. I can remote onto it fine by vnc and teamviewer.

I presume it is a graphics driver issue as I ran the battery down and plugged in the charger which results in the screen coming back on. My thinking is that there is something during startup that's causing the mac to boot to a blank/blank screen.

I've updated the CUD drivers and also web drivers from Nvidia, but still the issue remains when i reboot.
I have also done PRAM resets too.

Today i also updated to 10.10.3 in the hope that it would resolve the issue, but nope i'm still in the same position.

Looked all over apple support etc and tried a number of recommendations with nothing resolving the issue. I would do a system repair, but as i say can't see anything on the screen and at the moment haven't got access to a secondary display. At the moment i'm resorting to leaving the mac on, which is fine and even when it goes into sleep mode the display is fine. It's only if/when i have to do a reboot.

Mac is a Macbook Pro Retina (Mid 2012), Intel 2.3 i7.

Any help or advice would be really appreciated.

12 REPLIES 12

pblake
Contributor II

@g1za - If you boot from another device, USB or thunderbolt does the screen come back. I ask cause that will help you rule out a hardware/firmware issue vs. a software issue. If it works when bottled from another device, then it is software. If not, then it is hardware/firmware and I recommend going to Apple for support.

RobertHammen
Valued Contributor II

Be aware that there is a Repair Extension Program that includes the 2012 rMBP:

https://www.apple.com/support/macbookpro-videoissues/

Might just be a coincidence. @pblake's suggestion of trying to start up from an external drive is a good one. So would be the proverbial PRAM zap and SMC reset. If you get no video in any way, it's probably a coincidental failure related to the above REP.

Berrier
Contributor

@g1za have you tried resetting the SMC? I've seen that fix this problem when a PRAM reset won't.

htse
Contributor III

how far does it get before the screen goes black?

you could also use Safe Boot, which will startup with rudimentary video without all the higher-level video functions.

https://support.apple.com/en-us/HT201262

g1za
New Contributor III

I need to try booting from USB or thunderbolt next week, when i'm back at work and have access to some other Mac's. I need to use an external monitor to see what's going on during the boot as i can't see anything at all even if i do single user mode/Verbose mode, recovery mode etc and that's if it works.

I have tried to reset the SMC yes, but these Mac's are a bugger to get the battery out as they are stuck in!!!

The screen goes black as soon as the reboot takes place.

Thanks for your replies though.

@RobertHammen I've also found that too, but i guess i'd have to book in and pay for the Genius bar to sort it out.

jrblake2
New Contributor II

if you can ssh into the box & check, does this file exist? /var/db/.AppleUpgrade? Seen a few times where removing this fixes the black screen issue.

htse
Contributor III

SMC resets on modern systems are done with some keyboard acrobatics. https://support.apple.com/en-us/HT201295

also the Genius Bar does not charge for diagnosis at the bar, plus they'll have an external display.

g1za
New Contributor III

@jrblake2 Nope the file doesn't exist.

g1za
New Contributor III

Managed to try and connect to an external display, but both HDMI and VGA outputs don't show anything. System Pref doesn't even recognise it's plugged into another display.

Mauser
New Contributor

Hi g1za,

Did you manage to solve this issue? I've got exactly the same problem as you.
I've also got the mid 2012 Pro Retina. When I log in with the screen black, then close the lid and connect an external monitor/tv via HDMI and then open the lid, both screens turn on, but after a reboot the screen goes black again. This all happened also after the same security update.
I hope you found a solution in the mean time 😉

seattlemacuser
New Contributor

Had similar/same problem here: after Yosemite 10.10.3 update, my external monitor (Samsung) connected via HDMI from MacBook Air would work OK until machine went into screen saver. On return from screen saver, I would briefly see the login window, but it quickly faded out and Samsung screen would stay black.

To get the screen back required unplugging the video from MBA, turning the monitor off, replugging, opening the MBA to get screen back, and then turning monitor on again. Huge pain!

New Workaround: yesterday I discovered a solution that has been good so far: turn OFF screen saver. Instead, set a hot corner (System Preferences | Desktop & Screen Saver | Hot corners) that will "put display to sleep".

When I leave the MBA, I move mouse to that corner; display blanks and computer locks. When I return, hit Esc or move the mouse, etc., and display wakes and works fine.

Hope this helps -- and that Apples fixes this!

bpavlov
Honored Contributor

CTRL SHIFT POWER key (or EJECT key depending on keyboard) should turn the display off and lock your user session. I use it religiously similar to WINDOWS + L to lock your screen.