Broken Mojave installer?

New Contributor II

Hello and apologies if this is a bit of a noob question. I am trying to deploy a Mojave installer post-Catalina. I've got a script and everything to run the installer and it works beautifully. I downloaded the installer to a machine running Sierra using Apple's own link to download legacy OSs so I know it's the right one. The installer will run just fine on that machine. I used a USB drive to transfer the installer to my own machine, put it into Applications, created the package in Composer setting the permissions to root and wheel, then went through the process of uploading it and deploying it to several test machines.

The problem is the installer will run on certain machines, but then seems to "break." I run it manually from within Applications and the installer shows up in the dock but then refuses to run and needs to be force quit.

EDIT: I changed the permissions from root / wheel to root / admin and redeployed to a test machine and the installer works now, but I'm not sure if it's because of the permissions or because it was re-installed.

I'm completely stumped. Anyone else have this experience? We're not ready to move to Catalina yet so that's not an option.

Thanks for any and all advice.


Contributor II

Do you have any pics of errors or anything?
Also, in October, the Certificate in the Mojave installer expired. We had to redownload the installation package from Apple then reboot our target machines to get it to install without the "this package is damaged" error message.

New Contributor II

@luke.reagor Yes I was aware the cert expired with the release of Catalina and I did download a fresh installer onto a computer running 10.12. I know the error you're referring to but it's not that. Fresh installer not throwing an error message, it just hangs. Again I changed permissions in Composer so that could have something to do with it because once I reinstalled on a test machine with the broken installer it started working again. But I have a feeling it's going to break again.