Cannot Netboot Late 2016 Macbook with Touchbar

New Contributor

I have updated our NBI using AutoCasper NBI 1.3.4 using a base OS of 10.12.2 (16A323) and Casper Imaging 9.81. When I attempt to boot from the NBI it just comes up with a prohibitory symbol.

Is there something I might be missing here as to why this won't Netboot?

Just in case I am using a startech US1GC30W USB-C to Gigabit Network Adapter. Can anyone provide me some tips on what I should look for?

Thank you


Valued Contributor II

@mrperrott I know my 13" Touchbar MacBook Pro NetBoots fine using an NBI with macOS 10.12.3 created with AutoCasperNBI. Maybe that 10.12.2 build isn't a supported build. Can you recreate your NBI with 10.12.3 and repeat the test?

View solution in original post


Valued Contributor II

@mrperrott I know my 13" Touchbar MacBook Pro NetBoots fine using an NBI with macOS 10.12.3 created with AutoCasperNBI. Maybe that 10.12.2 build isn't a supported build. Can you recreate your NBI with 10.12.3 and repeat the test?

Valued Contributor III

I would suggest updating your NetBoot image itself (not your OS base image) to the 10.12.3 build... I don't know if old versions of the JSS would have any bearing on this but I know you should be able to NetBoot at least to a 10.12.3 make life easy I recommend using autoCasperNBI to build your NetBoot image...very intuitive to use

Valued Contributor

Use a base OS of 10.12.3.


New Contributor III

The quickest way I was able to get a proper NBI without over complicating this was to make an NBI image from the TB MBP.

Contributor II

I actually just competed making a new nbi of 10.12.3 using autodmg 1.7.3 and then autocaspernbi 1.3.4 And my 2016 MacBook with touchbar.
I did use the Belkin USB-c adapter that Apple sells.

Worked fine. Only problem was after reboot. The touchbar creates a new issue.

Check out this link for more info

New Contributor

As soon I used a 10.12.3 base image the device Netbooted with no issue.


Just chiming in with 10.12.4 update: bag of hurt with Touchbar macs.

2016 MacBook Pro with TouchBar
10.12.4 AutoCasperNBI on USB - boots
10.12.4 AutoCasperNBI on Netboot - no joy.

The EFI is the most likely cause:

I tried a little hocus pocus: created AutoCasperNBI, restore to USB, used Apple System Imaging utility to make a Netboot (in the hope EFI partition magic would occur)... while the kernelcache did change it was still no go using Apple's own tools to make a Netboot.

So I am almost giving up on that, 10.124. Netboot works for other models, but not the newest... so USB sticks for the techs right now... perhaps Apple will update System Imaging Utility or given enough hours in the day, make some über NetBoot dmg with an EFI partition that has the firmwares in it... but that is not sustainable. Netboot's beauty was supposed to be build once and run for all models.


I just received a 15" TB MBP preloaded with 10.12.3 from the factory... (Of course it was a forked OS)

Upon upgrading to 10.12.4 (to try and unify the OS), and creating my NBI with System Image Utility, the MBP will initially start the boot process from my Netboot server (show the globe), but will then show the no boot symbol alike in the first post.

I see that @brunerd is having alike issues...
Has anyone successfully booted a 15" TB MBP to a 10.12.4 NBI via netboot? I must be overlooking something?

New Contributor


I'm also having this problem this week, will try the USB method once the USB adapter has been delivered.

Any other update on the Netboot problem? - Was attempting this on a 15" MacBook pro with touchbar.

I did create a new netbook set 10.12.5 but no luck



Created netboot with 10.12.5 and no luck. Getting circle with line through it when netbooting.

New Contributor

So far we've had no issues using 10.12.3. Haven't tried with 10.12.4 or 10.12.5.

New Contributor III

hi there
received a new 2017 MBP 13" Non TB. i have not been able to boot this from any of our AutoCasperNBI boot disks - all been redone to 10.12.5 about a month ago. all boot attempts from external devices result in the no entry sign. tried various USB-C adaptors and even a USB-C to USB 3 cable - still the same.
i even tried to create a new AutoCasperNBI (10.12.5) boot image on this MBP to ensure any model specific drivers are imbedded, still no luck.
aslo made sure it's the latest version of Auto Casper NBI...

any ideas would be appreciated.

New Contributor II

@jacomaree Got this working today w/10.12.6 and a Dell USB-c - to -Ethernet dongle. 2017 MBPs appear to require a 10.12.6 base.

I did try a USB-C to Thunderbolt Thunderbolt to Ethernet Ethernet, but didn't get a successful boot.

New Contributor II

We got into this exact world of hurt after 10.12.5 came out... After some digging around I was advised by Apple to come in to the Apple store to have the two impacted machines re-imaged and to not use imaging anymore as it will likely be killed off with APFS anyway. Talked to JAMF at a conference a couple of days later and their push was pretty heavy for us to switch our workflow to DEP.

I've played around with the build images a bit, but eventually gave in and am in the process of switching everything across to DEP... Apart from a couple of issues with some of the older Macs I have to admit that it's been working pretty well... But I'm mightily frustrated that this sort of change lead to us effectively 'bricking' to Macbooks because Apple and JAMF either weren't aware of the potential impact of the changes that were being made, or they didn't feel that it was necessary to send out some sort of heads up.

The response that I got across the board was that it's a combination of a forked OS and issues with the IOS kernel for the touchpad devices... Which seems to be the recognised thing around here as well.

Good luck though ;)

New Contributor

For all the Techs having issues with Netboot and the new Macbook Pro meaning Late 2016 Touch bar. I've tested out many different dongles, and many work and many dongles. For those who get the stop sign upon trying to Netboot, please make sure you are using the right build. Meaning you would have to get a 15inch Macbook Pro and create a separate build for a 15 inch, and a separate build for a 13 inch Macbook Pro and iMac. The Belkin white USB-C to Ethernet cable that you purchase at Apple only works without issues. The White Tripp-Lite Dongle works also without any issues.

Hopes this sheds some light for many issues.

New Contributor III

This still does not work for me at all. Using macOS 10.2.6, which the machines themselves will happily boot from, I get only a black screen then nothing. It just decides not to do anything and then boots off the internal drive.
We've tried Belkin, we've tried Vrova, we've tried Comsol.
Further, USB-C iMacs will also not NetBoot, under similar circumstances.
In both cases, I can successfully NetBoot the device using a Frankenstein/piggybacked USB-C to USB-A adapter, coupled with an old USB-A to Ethernet adapter. Which means the OS should be fine. OS built using AutoDMG directly out of App Store macOS installer, NBI built with AutoCasperNBI. Boots other Macs no problem.
We are using the NetSUS appliance. Ours was a bit old, but still working (2.x) aside from this. We've upgraded to 4.1.0 but the problem is still there.
It's all very nice to say "just use the out-of-box OS" but keeping 350 heavily used student lab Macs fresh makes that approach unfeasible. I need a single-button approach that a monkey could reliably perform.

New Contributor

@deej I'm seeing the same black screen too. Regardless if I use verbose mode or just select the netboot at the option-boot screen, I still get nothing. This only seems to be affecting the TB-MBP 15" from 2017 (14,3) for us.

Base image made with 2017 TB-MBP laptop right out of the box. Netboot made with 10.12.6 installer direct from apple using AutoDMG and then AutoCasperNBI. I'm using the "white" belkin usb-c adpater, but still no joy.

It's so odd, you can see the netboot, you just can't get into it.

UPDATE TO THE ABOVE: our network speeds were different on the two ports I was using. I found that both server and target need to be on the same speed ports. So 1gig to 1gig works for us.