Casper Admin unable to mount master distribution point

New Contributor III

I think it's been a little too long without one of these posts

I recently upgraded our JSS to 9.91 and went to add a package with Casper Admin but I get the "master distribution point could not be mounted" error message.

What I've tried so far is:
-Casper Admin on another computer
-Via Wi-Fi and Ethernet on both
-Via Wi-Fi and Ethernet in the building that hosts the DP/JSS
-Changing the FQDN to IP Address of the server in JSS Settings
-Changing the port from 139 to 445
-Deleting and recreating the Main Distribution Point setting in the JSS and retrying the above steps
-Ran df command to make sure there wasn't a ghost-mounted volume for the Casper Share

On top of that, I can mount the CasperShare volume using my main JSS account so I know it's accessible at least. It is also hosted on a Windows server if that makes a difference.

Does anyone have any other ideas before I drop a support ticket in? Most of this information is what I've gathered from searching through a lot of past posts with the same problem.

Thanks in advance.


Valued Contributor II

Sorry if this is a duh, but are you sure when you open Casper Admin are you sure you did not already have the volume mounted?
You will get that error if you manually mounted it prior, or if it was left mounted if Casper Admin Unexpectedly quits for any reason.

Contributor II

I use AppleScript to get around this. Are you using a SMB share as your distribution point?

do shell script "diskutil unmount /Volumes/CasperCache"

I exported the script as an application and saved it in the dock. If opening Casper Admin fails or the distribution point cannot be mounted I just launch the app, that usually takes care of it.

But like @Sandy mentioned, it's most likely because the share is already mounted in the background.

You can always run a df in terminal to see whats mounted.

New Contributor III

Yeah it's an SMB share.

When I run the df command in Terminal these are the only volumes listed:

Filesystem 512-blocks Used Available Capacity iused ifree %iused Mounted on
/dev/disk1 974359808 126365408 847482400 13% 15859674 105935300 13% /
devfs 365 365 0 100% 633 0 100% /dev
map -hosts 0 0 0 100% 0 0 100% /net
map auto_home 0 0 0 100% 0 0 100% /home
map -fstab 0 0 0 100% 0 0 100% /Network/Servers
/dev/disk2s2 14444912 12526952 1917960 87% 1565867 239745 87% /Volumes/OS X 10.11 Install Disk - 10.11.4

No rogue Casper Share in there unfortunately.


Sounds like what ours was doing after updating to 9.91. Resolved it by changing from our full domain name (domain.loc) to just the simple domain name in the "file sharing" tab. See this thread for more:

Valued Contributor II

This post helped us (from our rock-star TAM).


New Contributor III

Great advice @cgalik and @dan.snelson! I unfortunately left my imaging computer at the one school since I'm locked in a mortal battle with one of the iMacs and need to go back, but I'll give those suggestions a try first thing Monday morning. I know our domain is set as "domain.localnet" so I'll try it with just "domain" and worst case nothing after that. Thanks again.

Contributor II

Make sure your casper share names don't have spaces or special characters. I had to change mine to resolve the issue.

New Contributor

I created the share on a Windows server and was having the same issue. I had to make sure the 2 accounts I created to access the share had the correct permissions and that share was on the root of the drive.

New Contributor III

Hi everyone,

Sorry for the delay in getting back, but I wanted to add an update that changing the domain in the Fileshare tab to the simple domain name fixed the issue.