Casper GSX connection behind Proxy not connecting

Dougvo
New Contributor II

Hi All-
Saw a question long ago on this topic but no responses. We have our Casper server behind BlueCoat proxy hardware and the connection to the GSX service in Casper does not work. It just sits at 0% of xxx number of computers. I know it has something to do with the proxy as the proxy was down one day and I ran the GSX connection and populated the computers that were in inventory at that time.

Does anybody know what URLs and/or ports need to be opened/white-listed in a proxy in order for GSX connections to communicate both ways? I cannot seem to get a definitive answer from Apple, and my tcpdump and Fiddler reports are a swamp of info.

Thought I'd ask if anyone else has had to deal with this first.

Thanks,
doug

4 REPLIES 4

talkingmoose
Honored Contributor II

Does your proxy require authentication? If so then your solution probably won't be whitelisting a site. You need to get your network admins to not require authentication to your proxy for your server.

Is authentication all or nothing with these BlueCoats? I don't know. We actually have an alternate proxy that doesn't require authentication for situations like this.

Dougvo
New Contributor II

Yes...the proxy does require authentication. I probably incorrectly stated this as "whitelisting" which is only part of the setup. The other setting on the proxy that we have used is to set particular URL/port combos to "noauth" which means they will pas through with out any required authentication.

The problem seems to be getting the correct URL/ports.

Olivier
New Contributor II

We also have Bluecoat, but with no auth.

Anyway, I managed to make GSX to work by adding following stuff to /Library/JSS/Tomcat/conf/catalina.properties file:

http.proxyHost=yourProxyURL
http.proxyPort=yourProxyPort

In addition you can add this :

http.proxyUser=yourUserName
http.proxyPassword=yourPassword

It would be great if Jamf database utility could add this feature in the "configure Tomcat" menu.

fritz_schlapbac
Contributor

Here is a tip for the proxy settings when using a Windows 2008 R2 Server:

The catalina.properties, catalina.bat and setenv.bat files are not used when Tomcat runs as a service. You have to set the proxy settings in the following registry path.

HKEY_LOCAL_MACHINESOFTWAREWow6432NodeApache Software FoundationProcrun 2.0Tomcat7ParametersJava

In this registry path open the "Options" key and add the following settings to the existing entries:

-Dhttp.proxySet=true
-Dhttp.proxyHost=proxy.yourdomain.com
-Dhttp.proxyPort=8080

After restarting Tomcat GSX is working now for me.